SGP Image Time Not Working

I am unable to solve this issue and have searched this forum and others for idea’s:

Attempting to take 300 second images with a Canon 600D. At start of image, shutter opens but then closes unexpectedly after only 1 to 2 seconds. SGP sequence window continues for full 300 seconds and then downloads the 1 to 2 second image. (It stamps it as a 300 second image.) Cannot figure what is wrong.

Camera works properly with intervalometer and when using the ASI Air software for imaging. I have checked cables, tried new cables, ran Ascom diagnostic tool. All other gear running fine with SGP. (Auto Focusing, Mount, Plate Solving and Guiding.)

I have several SGP sequencing profiles saved, this occurs on multiple profiles.

This started two sessions ago (did not recognize that I had an issue until downloading my evenings images and started to process with PI). Worked fine previously. No (conscious) changes made to settings that I am aware of.

Appreciate any suggestions…thanks!!


This sounds like you have the mirror lockup enabled in the camera and potentially not in SGP, or the other way around. Basically if you have mirror lockup enabled in the camera you need to make sure that the mirror setting time in the canon settings is non-zero. And vice versa if you have mirror lockup disabled in the camera then you need to have the mirror settle time set to 0 in SGP.


1 Like

I ran into the exact same thing, (with the same camera model, even!), and it was because I had Mirror Settle Time set in SGP, but did not have Mirror Lock Up set in the camera menus. Once I fixed, all worked as expected; mirror clicks up, then 2 seconds later (since that’s what I had set), the shutter goes. And it still works in BYE’s mirror lock up setting, if you use that too.