SGP not downloading frame and focus - need help interpreting log

We had an electrical storm a few night ago. All equipment was surge protected but since the storm I have been having problems with SGP. Tonight it was failure to download a 10 second frame and focus. First time I aborted, SGP froze. I restarted and I think the attached log covers the last failure. I have other logs from the night if needed.

I am wondering if one of more of my files is corrupted, or if there is some other problem. Unfortunately I cannot interpret the log and would love some help to see if I can isolate the problem.

Many thanks, Ed Wileysg_logfile_20170810215341.txt (46.2 KB)

Today I performed the following:

  1. Atik Drivers – Checked, the program “Artemis.exe” immediately opens the camera and I took a snapshot
  2. ASCOM. Diagnostic run – 1373 matches, Zero exceptions, 2 errors, both referring to Gemini which I no longer run.
  3. SGP. I can only describe it as erratic. Today I connected all components. In two telescope positions (parked and zenith) I ran both frame and focus and a series of darks (no lights due to PhD settings). Everything worked fine, no problems (!).

This reminds me of the last time I took my MG to the mechanic.