SGP not parking dome correctly

I’m working on the setup of a dome observatory and found some weird behaviour by SGP where it tells the dome to park (to the correct position), parks the mount, after that it starts slewing the dome again to match the scope position (park position is different for the scope and the dome)

I believe SGP should turn off dome slaving when parking the dome, would it be possible to have this added as an option or just simple edit the current function of “slave on sequence start”?

This was brought up before and I thought Jared fixed it. However, lately, I see the same problem as you. Do not know whether or not I should say AGAIN…maybe the problem never went away. I have done very little imaging of late, that I have not concentrated on getting the logs that Jared/Ken will look for.
Bottom line…I am seeing the exact same problem as you…just have not done any worthwhile tests of late to give Jared/Ken the info (logs). If you have logs they will appreciate them.

Jared…agree with ‘Xplode’ here. I have seen the dome go to park position at the end of a run (when the mount was on its way to park). Dome reached ‘Park’ position first then took off again to slave to the mount position. The mount reached the park position …then the gear was disconnected (as planned)…but the dome was neither here nor there…caught in the middle of a move it should not have done.
When the gear is fired up the next night…without having been parked…the dome reports the wrong position angle and needs manual input…i.e. auto start up not possible.

Looks like with moon up…I can do something to generate logs if you really need them.


I think i will have to produce a new log to make sure it contains what they want to know for sure.

I also found a lot of logs contains a lot of garbage like this, i searched the forum and found people have complained about it before and thought it was fixed…
[03.28.18 09:12:35.902][DEBUG] [CP Update Thread] Caught exception in CanPierFlipNow : Objektreferanse er ikke satt til en objektforekomst.

I have observed this same behaviour as well - for last couple of years. I am still not certain if this is an SGP issue or a dome driver issue. Perhaps if observed for different domes, that would suggest the former? My dome is Foster System controller (AstroMC).

I’ll try to save a log as well, next time I’m out. For what it is worth, I am still on

This is an issue for me because if the dome does not go to its Park/Home position, the shutter battery does not get recharged. And if I don’t remember to home the dome the next day, it is unhappy times the next clear night (which is often not until many days/weeks have passed).


Logs would be good. Was this with I can’t recall if the fix for this made it into that version or if it’s still waiting to get released. I’ll have to look through the change logs.


Hi Jared,

Yes…I am running the latest version

I’ll see what I can do tonight - just a trial run - to see can I repeat those conditions mentioned with logs (SGP & Dome).

I thought you mentioned a fix quite some time ago but as my imaging has been very sporadic, I cannot say for definite if in fact it actually was fixed in a previous release.

I don’t need to be imaging to do this…I’ll try a run very shortly.


From the test today….this is a brief. All the real info is as per log. (link below). My times here are not exact….just taking notes as I tried a couple of things. These are perhaps not my normal routine steps – just done for test.

1559 Unpark mount in Sky X. Sent mount to NW (Mount normally parked in SE
1601 Start SGP
1602 Connect equipment for a test run. Slave Dome and it goes to NW & aligns with mount
1606 Start/Abort sequence (Still daylight….just wanted to actually ABORT the sequence for testing). Scope moves off to park position. (Park mount 1st is selected).
1608 Mount parked, dome now follows.
Dome aligned with the mount but did not actually go to park position.

2nd Run (park mount first is NOT selected)
1612 Unpark mount and send to NW in Sky X. Mount moves first to position – dome then moves & aligns.
1616 Dome lined up.
1617 Start/Abort sequence. Dome heads to Park position. When the dome parked, then the mount heads for park position. When the mount starts moving toward park, the domes comes off park and heads back to align/follow with mount.
1619 Dome aligned with mount - the mount is at park position but dome is not.

There was one test done earlier where the Mount and Dome actually both parked. This was when (not in a sequence but well away from park position & “Park mount first” was NOT selected). Dome was slaved to the mount and from inside SGP, I selected to Park the mount. In this instance the Dome moved before the scope and went to correct Park position. When the dome was parked, the mount then moved to the correct parked position.
The same test was done (outside a sequence) but this time with ‘Park Mount First’ selected. When the mount parked, then the dome followed – but only aligned….did not actually park.

Note: I deselected the dome after each test and reconnected it in its own ascom driver to check whether or not it had actually parked. When it actually parks - it holds position and starts up again with correct angle noted. (If it does not actually park at end of a sequence, I have to ‘Home’ it at the start of the next session, so that it acquires the correct position angle).

I hope the above (& link) are of help.