SGP reports very strange temp on ZWO 071MC-c = 55 celcius - APT says its at Zero? Also no BayerPat set though driver detects RGGB mask

Resolved - some decent dectective work below for what it’s worth! Key learning is the ZWO Bayer pattern though detected by the driver - doesn’t seem to autopopulate the Bayer pattern in the Control Panel → Camera tab; might want to consider this option / default!


I haven’t encountered this one before - so two issues with a SGP controlled ZWO colour camera - CMOS temperature seems way wrong and no Bayer pattern (RGGB) stored in created FITS files.

I needed to update my Dark frame library for my SGP controlled scope and a ZWO 071MC-c Pro camera.

SGP reported the temperature as 55 degrees Celcius - when the outside air today is 23 degrees and falling. So it couldn’t get to 0 degrees - even at 100% power (from a lab power supply). I diconnected the camera from SGP and switched over to APT to control the camera and run its cooling aid - it reported the temperature as 0 Celcius - the target - within 5 mins. I puased the Dark library creation script in APT and when back to SGP - it connected to the camera and reported the temperature as 55 degrees again.

I get a feeling APT is getting the correct temperature of the Camera and SGP think it is roasting - what suggestions might you have. I will try The SkyX to grab the camera too and see what it thinks the temperature is - TSX says 55 degrees too.

This is weird - is it a reload ZWO drivers - I don’t get why with no changes to drivers 3 camera control programs think the camera temperatures are so different!

My second issue is althought the ZWO driver in SGP says a RGGB bayer pattern is in effect - no bayer pattern is stored in the image - checked by viewing a SGP created image in ASIFits view. It shows APT stores the Bayer pattern for this camera whilst SGP doesn’t. Is this something I explicitely have to turn on in SGP?

I can edit all my images created with SGP later (I had to do this for several thousand images last night once I realised the Bayer pattern flag was missing from all the SGP created images. Luckily F2W2HDU can read and re-write the Bayer pattern file to all my fits.

So running my darks in APT right now - with the Bayer pattern enabled for that colour camera enabled and ASIFits View for the darks correctly show RGGB Bayer mask. I just tried 4 x 60 second darks with SGP and viewed them in ASIFits View - it said each image had no Bayer pattern present - so thought it was seeing a mono pattern.

So this means - meaning the FITS header tag BAYERPAT isn’t set. I believe each image should be stored with this tag set to a value of 'RGGB '. Is there a specific seeting need to apply in the Camera set up - even though RGGB bayer pattern is detected by teh driver - to tell SGP to save all images with the Bayer pattern filled in.

Many thanks,


OS: Windows 10 Pro

TSX camera temp

I am not sure if the cooling seeming to act like heating isn’t actually an issue with my camera’s hardware sad to say… powering it off for a few hours to cool then will try again.

The Bayer Pattern tag missing from the FIT file is still an issue - is it a simple configuration setting?

Okay - so I found my own answer to the Bayer Mask - I see in the Camera tab under the Control Panel - that Bayer mask wasn’t entered - even though the ZWO driver specificies the correct Bayer mask as RGGB.

So I entered that in manually and did a quick test run and ASIFits Viewer showed each frame now has a BayerMask Pattern set!

71MC Bayer pattern

For my other issue of cooling - I think that is a failing cooler TEC on the ZWO camera - so I might buy another one second hand - but I have emailed ZWO support to ask is it servicable / economically fixable?



Bought a second of these cameras - second hand - cooling working fine now - so that is problem 1 sorted whilst the original camera ges serviced.

I am still having a configuration issue trying to get SGP to insert the colour Bayer pattern RGGB into the files. Started a dark run now - it isn’t placing the Bayer pattern setting into the fits header

Also when I select this new camera I can see in the driver settings it is RGGB, but when I open the Camera offset tab in the control planel shown above - under settings and gain the Bayer pattern and X Y offset field no longer appear - so what do I need to tweak please?

Is it placing anything for that pattern is it just missing entirely?

Can you clarify here? What do you mean by “they no longer appear”? Do you mean to say that you enter non-zero values here and then at some point they disappear and are reset back to 0?

Hi Ken,

The Bayerpat field is simply altogether missing when I use SGP to drive the camera. It’s easy to add after the fact with a database update to the 100s of images I shoot - but I would prefer to capture the data at time of acquisition.

I will try the camera tab again today - when I did it last simply only the Left hand side of the screen presented - the RHS with the Bayer pattern and offset fields simply weren’t drawn. Let me try again just now to see if it were an user error situation on my part.

So just ran it all again,

The RHS of the Camera tab appeared again - so I set up the Bayer pattern and are recreating some long darks (4 - 6 minute shots).

In ASI Fits Viewer all have the Bayer pattern - so big win! The first shot at 2.9 degrees was incredibly green - but all the rest at 0 celcius look like totally normal colour dark frames now.

So not sure what had occurred - I have 5 ZWO cameras attached concurrently - looks like a driver confusion possibly - (could always be operator confusion but when I posted I checked 3 times first).

All good now and will keep an eye on it - but generally when it is fixed it stays fixed!

Many thanks,


1 Like