SGP says about Canon D90 "error connecting to canon EOS"

Hello, new user here and just figuring things out. I’ve read the documentation and searched my issue with no direction/help just yet so thought I’d post here.

Using a canon 90D and am trying to connect it to SGP but a window pops up with “error connecting to canon EOS”

My ascom drivers and software are up to date including the camera drivers. I setup the profile in SGP for my canon 90D following directions and a few you tube guides.

The focuser connects and so does the mount but the camera isnt’ being recognized. I’ve checked connections, the camera pops up in other applications so I know the computer sees the canon.

I’ve setup the canon for astrophotography settings but maybe there’s something specific I need to do for SGP? I have the canon set at manual and have tried bulb - same error. Camera connections/battery/power are all good.

what am I missing?? thx much for any guidance provided! Cheers!

what am I missing??

SGP to have the correct Canon SDK version to support this camera :grimacing:

I’m working on updating to a newer SDK. If you’re open to it I can get you a release to test with.

Thank you,

Version will release today and have the new Canon libraries that support this camera. Please not that we don’t have this camera for testing and are not able to verify before release. That said, if there are problems, we will work with you to correct them.