SGP Seletek position issue

Hi There,

This is my first topic over here, since yesterday i have a problem with my autofocus routine in SGP.

The error message is : Error in auto focus! Current focusser position does not support required range ( currently at 3660 and needs to move outward to 3780 which is above your focusser’s maximum outward range of 3 steps)

If i take a look at the Seletek settings my maximum outward positions is way up to 4800. and the focusser is not at his drawtube outher limit.

Also, in sgp, I can not give in and out of commands more to the seletek.

(After these problems, I have upgraded the seletek software and installed the latest version of SGP and the problems remain the same.)

Please some advice :slight_smile:

Best regards,


Hi All,

After another hour, I got it back to work. Eventually all settings were checked and compared to before and eventually nothing changed.

The problem is solved, only the cause is completely unknown to me

The topic may be closed in my opinion (or deleted)

Best Regards,


Hi Vincent,

this is Jaime, the author of the Seletek and also a SGP user :slight_smile:

If it’s solved, it’s ok - even if I’d rather solve all software mysteries.

If it repeats or whatever I’ll keep an eye here.

Best regards,


1 Like

As always, excellent support for Seletek users from Jaime

Top man.