SGP Stops After Centering - Waits for PHD2?

New camera and guider installed. Tried running a sequence last couple of nights and SGP always stops after successful auto-center, then turns on auto-guider and then just sits there. Should move to an auto-focus frame before starting the sequence. Looking at the log file - at time [01/07/22 19:10:55.188] is where things hang. At that point, I abort the sequence. Unable to figure out what the issue is at the point when SGP is waiting for PHD2.

Log file is here: https://1drv.ms/u/s!AiykFZb1zO59gYMUwDtRg4jLOZ3RfA?e=Cfz7Fy

Thanks for the help.

Jerry

There are a couple of things going on here:

  • SGPro is waiting for PHD2 to start guiding. Approx 6 minutes later, SGPro receives what I assume is an error message with additional information about why it is unable to start PHD.
  • Unfortunately, this error message produces its own error message when it attempts to display it (the reason is unclear)

I will release beta 4.1 build 728 a little later today. If you’d like to try that version, it has some additions that, while they won’t fix the issue, should give us the information we need to find and fix.

Ken,

I watch PHD2 start up and begin guiding … so there is definitely some communication or configuration issue.

I’ll give the beta a try once you release it.

Thanks for the quick response.

Ok. The 728 beta should be available in about 30 min. A few notes:

  • SGPro 4 will not detect the 4.1 beta with “Check for updates”, you’ll need to go here to download 4.1.0.728 => https://www.sequencegeneratorpro.com/downloads/#1589668528967-44caedd2-746d
  • You dont need to uninstall 4.0 to use the beta, but, by default 4.1 will install 4.1 over top of it
  • Earlier in the beta there were some problems using sequences in 4.0 that had been opened in 4.1. Im pretty sure I have addressed those issues, but it’s best to make copies of the sequences you want to use in 4.1 and use those to test.
  • It is beta software, but 4.1 is actually pretty close to release just being extra cautious because it has not passed final testing.
  • Just to re-iterate, there are no changes to address the issue you see, just changes to assist in its detection.

Here’s the link to the log file for tonight. Upgraded to latest Beta.

https://1drv.ms/u/s!AiykFZb1zO59gYMUwDtRg4jLOZ3RfA?e=zNTv3F

Quite the mess. Even though it went through the autofocus, after that everything locked up. Had to power down the entire system in order to recover.

Let me know if you need more info.

Ken,

I was looking through the SGP log from last night.

Noticed that there were a number of reports of not being able to communicate to PHD2.

I looked at the PHD2 Connection Settings and noticed that the PHD2 Server Options was set to port 4400.

Looking at the PHD2 wiki on the server port ( https://github.com/OpenPHDGuiding/phd2/wiki/SocketServerInterface ) it states that “PHD2 listens for TCP connections on port 4300”.

Do you think this may be the problem?

OK - nevermind - 4400 is the right TCP Port …

It seems like everything started mostly normal here… good auto focus, good centering, then you lost the guide star and things went downhill from there. After losing the guide star, SGPro went into automatic recovery mode and when SGPro asked the camera to abort its current integration, it eventually did so but then started emitting very odd error messages for subsequent attempts to use it. At this point, all hell breaks loose and it’s unclear why. The camera will not respond, the PHD2 socket is dead, the connection with the mount is lost and the connection with the camera is lost. When everything “locked up”, the logs indicate that SGPro was engaged in the normal recovery process and just waiting to start the next recovery attempt, but Im guessing that you did not see the recovery window on the screen. Are you using RDP or similar?

Also, fwiw, this session had nothing in common with the original failure you experienced, so unsure about that as well…

Questions to be answered (not necessarily by you):

  • Was it cloudy or was the guide camera obstructed in any other way? Does it seem likely that the guide star could have been lost?
  • Why did the entirety of the ASCOM platform seem to fail after the guide star was lost?
  • Did you see the Sequence Recovery window displayed at all? If so, was it present when you say SGPro locked up? If not, do you know when it disappeared?

Ken,

I ran some tests over the last few days and figured out that I had a comms problem. I recently bought a new Starlight Xpress camera with an OAG and an internal USB hub. I was running the OAG camera through the main camera USB hub. I ran a test where I started PHD2 guiding manually then went over to SGP to take a picture with the main camera. When I did that, everything froze up. If I took pictures with the main camera and PHD2 not running, everything worked fine.

So the next day I disconnected the guide camera from the main camera USB hub and ran the guide camera USB straight to a USB port on my computer.

I was able to get through an SGP sequence last night without having the system crash like I had seen before.

It could have been just blind luck and there still may be an issue, but everything seemed to be working OK - guiding, centering, autofocus, pictures.

Go figure …

Thanks for your help and taking a look at things - forced me to look more closely at my setup.

1 Like