SGP stops working when using Mosaic feature

I was trying the Mosaic feature for the first time. Everything seemed to work fine up until SGP tried to restart PHD guiding after the centering routine , then the trouble began.

The windows error message window pops open and says SGP has stopped working and windows is looking for a solution (yeah, sure it will). Of course this doesn’t work and I have to start all over. Anybody have any ideas as to what is wrong. I was using the older 2.2 ???. I just updated to the newer 2.3.15. Will this fix the issue ?? Has it anything to do with the ascom driver I am using in phd to run my starshoot autoguider ??


Dennis, please try the new 2.4 release. Also please note that 2.4 sequences are not compatible with 2.4.

I think Ken means 2.2 sequences are not compatible with 2.4.


trying new release …now it won’t plate solve with astrometry…help…will not even solve and sync.

What is the error? Can you bring up the command line window and run a plate solve? Did you reboot the computer? I’ve noticed on the 2.4 installs rebooting is mandatory.


did not reboot…will try…thanks for the quick response.


Here is a handy list of stuff we usually need to help. Rebooting is not strictly necessary, but there is no need to debate that here (if you do need to reboot it is likely that the state of equipment was reset as SGPro does nothing special during OS start).

I updated to 2.4 as instructed by Ken to solve my Mosaic problem. Problem is now I can’t even do a simple Solve and Sync. Keeps saying Plate Solve Failed. I am using I also rebooted as instructed by mads0100.

Help …please…



Did you read my post above? We can’t do much to help you without more information.


I read instructions on how to ask for help. It said to post to the specific category…for ex…Plate Solving…so that is what I did BECAUSE I am having plate solving issues with the new SGP 2.4 So then you decide to lock my post as a duplicate. What would you like me to do so I can get a simple answer to a simple question…1. It will not solve and sync 2. It will not plate solve using Please tell me what I am missing so we will both know . Thank you.

btw…I looked through all the help files…am I missing the answer there ?? Everything was working just fine with the previous editions of SGP as far as solve and sync and plate solving is concerned

The category may be right, but switching to a new thread mid-request, does not give an accurate portrayal of the steps you (we) used to resolve your issue. Regardless, the category is not that important.

From the instructions on how to ask for help:

I did mention it was Windows…specifically Windows 8.1 . I did say on several occasions it is the new SGP 2.4. I tried finding a log file…no luck. It was a new sequence . I was simply trying to do a solve and sync so that my mount would know where it is. I then tried several Plate Solves using . Never had this problem with previous editions of your fine software. I don’t know what else to tell you. I even uninstalled and reinstalled SGP 2.4sg_logfile_20150316223724.txt (28.5 KB)

wow…I found a file …finally …hope this helps, if I loaded it right.

This section of the log looks as if it is saying what the problem is…

[3/16/2015 10:38:45 PM] [DEBUG] [Telescope Thread] Astrometry.NET using endpoint:
[3/16/2015 10:38:45 PM] [DEBUG] [Telescope Thread] Astrometry.NET - Calling Async Solve
[3/16/2015 10:38:46 PM] [DEBUG] [Unknown] Exception in Astrometry.NET Solver: Unable to connect to the remote server

SGP is unable to connect to so the image can’t be solved.

Didn’t the message saying that the solve had failed report this?


Hi Chris,

The only message that popped up in SGP says “Failed to Plate Solve Image” . So I guess my next question is why is sgp unable to connect to the remote server. I just downloaded one of my images to sgp and tried a plate solve, it shows all the hints but the Search field is not filled in …it says “Not Available”, drop down menu shows no options even though I have specified Astrometry. net in the control panel and the Equipment Profile Manager.


Dennissg_logfile_20150317073521.txt (20.2 KB)

You should look if a firewall is not blocking SGP 2.4 .

[3/17/2015 7:35:22 AM] [DEBUG] [Main Thread] Checking for valid internet connection…
[3/17/2015 7:35:22 AM] [DEBUG] [Main Thread] Error validating internet connection: Unable to connect to the remote server

I have shut off my Firewall completely . Previous versions of SGP worked fine. Loaded the new 2.4 version yesterday and the problems began. Any other suggestions would be helpful …



SUCCESS…Thank you FDX…you nailed it. It was a Firewall setting somewhere that was blocking. All seems to be working correctly now. : ) Now I just have to figure out why the Firewall is blocking sgp .

1 Like

You should be able to add an exception. Glad you figured it out!

when a software updates (from a version to an other ) the firewall rules has to be updated also to account for the new version of the software thus allowing it to communicate through defined ports…

happy to help…


1 Like

thanks guys…it was a long night…and early morning …appreciate the help and patience.

1 Like