SGP temp compansation focuser and more

First I like to apologize for my bad English, but I have
some problems with SGP which I cannot solve myself.

When I connect my QSI583wsg camera the camera is cooling
down and the Fan is at full power. The fan allways remain on full power even if
the camera is on temp or if it warms up. FAN Option Quiet mode  is not affected in the QSI driver, it is
allways full power.

I have a SharpSky focusser with temp control and ASCOM
driver. The temp control of the focusser is switched off , in ASCCOM, when I
connect the focusser in SGP. SGP can read the TEMP sensor when connecting, but
is not updating the temperature so no corrections are send to the focusser. The
Temp Compansation Trainer does not switch the TempCompEnabled option on in de
Ascom driver.

I have iOptron iEQ45 mount, SGP can connect the Mount,
but it only read the Ra,Dec,Alt and Az value, it cannot move the Mount. The
arrows are all gray and cannot be pushed.

With Starry Night Pro 6 or 7 and with POTH Hub I can move
or possition the Mount. I cannot park the Mount, this option is not availeble
in the iOptron ASCOM driver, I know. In SGP the telescope is connected with the
POTH hub.

In case off guiding, SGP only reads the PHD log file, but
cannot send any information to PHD or start or stop guiding or what ever.
Server settings are on in PHD. Maybe this is related with the issue above.

There are a lot of problems I know. Some may be related
to each other.

My biggest problem is the Temperature  Compansation on the focusser and the Telescope

Note: SGP version,  ASCOM version 6.1, PHD 2.2.1, ScopeDome
RollOffRoof connecting ASCOM via Generic HUB or POTH HUB.



1.) Camera Cooling: SGPro does not control the cooler or fan. We only ask that the camera goes to a particular temperature. If your fan is always running, then you may have a defective cooler or you may be trying to cool beyond the capabilities of the camera.

2.) SharpSky Temp Reporting: Not sure. We have other users with Sharpsky focusers that do not report this issue. Please ensure your drivers are up to date. SGPro uses its own temperature compensation, please don’t confuse this with your ASCOM drivers internal implementation.

3.) iEQ45 is not compatible with the SGPro nudge panel. Please contact iOptron and ask them to implemtn the “Move()” method.

4.) Starry night pro uses “Slew()” to move the telescope, we chose to use a different method(). This is why you can move your mount in Starry nights with the nudge commands. There should be no problem with Park… we ask the POTH hub to park the mount and it should relay that to your iOptron driver.

5.) Not sure about your PHD issue.

Thanks for the replay. I know that the camera is working well with MaximDL.
I try to work it out.All drivers are up to date. Maybe SGP is not suitable for my setup.

We have many users that use the same gear as you so I wouldn’t go so far as to say that SGPro is not suitable for your setup. I have personally owned and used SGPro with both a QSI 583 and 683 with no issues. The iOptron ASCOM driver could use a bit of work to make it friendlier (at a minimum providing a driver that can accept multiple connections)… We have even gone so far as to offer to write their driver for them, but we have received no response. That said, we never try to force SGPro on anyone… if Maxim is working better for you, then maybe you should head in that direction. It’s all about being happy… :wink:

Hello, i’am a new user of sgp and experience the same problem with qsi fan.
It is well functionning on maxim (once temp is reach, the fan become quiet ) but not in sgp… any help please ?

thanks alot

Some more info

By choosing the ascom chooser for the camera, the quiet function is ok
sadly, i cannot use the filter wheel this way…

THe only trick is to make cooling down the cam with the ascom driver, then to reconnect with the native
driver…dohhhh !! not very automated isn’it ?
thanks for your help , the whole software is very good, only this is annoying…



I don’t think we can help you much here. We ask the driver to go to and stay at a certain temperature and that’s it. We let the driver control the camera’s destiny after this… I cannot speak to why other programs control the camera differently. We are following the directions QSI has published for camera control.

Also, I am not sure why this is really a problem. I have imaged for years with a QSI camera and, while the fan does stay on, the camera maintains temperature just fine and does not interfere with imaging in any way. Most camera fans stay on when the tec is on.


Hello Ken, this is just noisy and annoying…uncomfortable…
The qsi driver allows this feature so…it is a loss here…
Notice that the fan will go full speed only if sgp ask the driver to change the temp…

Strangly this works with the ascom driver…
do you think i shall ask qsi ?

Hello, after testing the “problem” is still there , and an astrofriend with the same setup experience the same behaviour.

Qsi 683 wsg8 with the last qsi drivers/firmware.


-camera plugged to laptop
-camera is on
-sgp launch
-qsi camera selected on sequence
-setting the qsi camera on quiet mode
-connect the camera
at this point the fan is low
-switch cooler ON
at this point the fan goes full speed and never change this state, even if temp is ok
-switch off the cooler
-disconnect the camera
-in the settings the fan mode is now on full speed by itself

So the workaround of this “problem” is
-first connect the cam
-switch on the cooler
-disconnect the cam without switching of the cooler when sgp ask it
-set quiet mode in cam settings (sequence)
-re-connect the cam

from now and durring all the session, the cam will work in quiet mode.

Quiet mode ?
quiet mode adapt the fan to lowest speed needed to acheive
the temp regulation. If external temp condition changes, the fan will automaticly speed up
to reach the set temperature, and will slow down if possible…

Qiet mode and it’s value -
-it’s quiet :smiley: !!
-better temp regulation
-less vibrations (fans…)
-augmented fan life

any comments ?

By the way i’m really impressed with SGP !! wonderfull work !

None right now except to say that SGP seems to be incompatible with quiet mode. We will add this to our request list. I am not sure why this happens. If you set the Camera to quiet mode via the SGPro camera settings, we do nothing to change it during the temperature change process.

We may target this for release 2.5. This is not high enough of a priority to break the 2.4 feature lock we apply during beta testing.

Thank you for posting the workaround. Glad you are enjoying SGPro

Thanks ken, of course this is not priority, just a confort thing…

To be more accurate about the behaviour it is when cooler is switched on that the driver return the fan mode
in full speed.