SGP tries to connect to focuser although 'No focuser' is defined in the sequence


I created a new sequence only for capturing calibration frames. In this sequence, no focuser is defined. Nevertheless SGP insists to connect to the (not cable-connected) focuser when the option ‘Temperatur Compensation’ is enabled.

Please make sure that this nonsensical request will not be performed. It took some time to find the cause of this issue.


Link to Logs

Useful Info

OS: Windows 11 Pro
Ver: SGP (64 bit)

So obviously Temperature Compensation requires having a focuser attached so that SGP can adjust focus as the temperature changes.

I agree that it can sometimes be tricky to track down which specific SGP setting is causing an action (like “connect to focuser”) to occur. Maybe a better approach would be for SGP to display a warning at the start of the sequence with something like “*Temperature Compensation is disabled as no focuser is defined”…?

There are actually, literally, hundreds of messages like this at sequence start including this one. I am not sure if it didn’t show (a bug) or if it was ignored:


I didn’t see a warning. However, I would not expect a warning either:

The use of temperature compensation is defined in my equipment profile, which of course contains the focuser as an equipment. When I create a new sequence and deselect the focuser by choosing ‘No Focuser’, my expextation is that SGP will NOT try to connect to the focuser when this sequence is run.


Interesting - I guess I haven’t had a sequence misconfiguration is a long while, so haven’t seen any of those messages! :slight_smile:

This is not really an expectation, but rather a philosophy that we have chosen to not implement. When two settings contradict each other… in this case, “perform temp comp” and “do not connect to a focuser”, we can assume one of 2 things:

  • You have made an error and you expect temp compensation, but do not have a focuser attached to the sequence
  • You have not made an error and this is your intent and we should ignore all commands that involve the focuser.

I will tell you that, initially we subscribed to the latter (the one you want), but it literally created a scenario where we spent 2-3x as much time on support answering “why did this not happen” scenarios.

In this case, it seems like we have a bug and you were not informed of the settings mismatch. If you want to provide the sequence, I will take a look and correct,

Even though a feature that requires a focuser is still enabled by the user? So if a user disables the focuser SGP should automatically disable all focuser related options (uncheck the boxes), or just ignore them?

I think the challenge is for SGP to know what the user “really wants”. If you disable one feature (focuser) but enable another (temp comp), how does SGP know what the user really wants?

So yeah, one option could be that f someone disables the focuser in their sequence, SGP could automatically disable or ignore all focuser related options, regardless of whether the user enabled them or not, and just continue with the sequence. Or another option would be for SGP to display a warning that this sequence requires a focuser because other features (like temp comp) are enabled, which apparently is what it is currently doing.

Personally I prefer the second approach - I’d like to know if there is a misconfiguration or conflict in my sequence settings. But I can see why people might prefer the first option.

OK, I understand your point of view.

I will try again (with ‘No Focuser’ and temperature compensation enabled) and watch out whether the notification appears, maybe that I missed it.


1 Like

OK, I tried it again. When the sequence is started, the following error message appears, no notification.

And now I see the hint: “Sequence uses temperature compensation…”

Sorry for the trouble. Obviously I didn’t get it.

The sequence is appended:
Offset_Test.sgf (35.3 KB)