SGP trying to use equipment that is not connected

Version i.e. latest
Normally use an iOptron mount with a large SCT and the ZWO 294MC Pro but last night I tried to use the camera with a short refractor and portable unguided mount (Star Adventurer).
I therefore started a new sequence and selected the camera to be connected but set the telescope and focuser to be not connected.
When I tried to run the sequence I got an error message that it could not see the telescope to perform the meridian flip. I then went to the control panel and unclicked the meridian flip. It then gave me an error message about not being able to connect the autoguider. I then had to go into the control panel and deselect the autoguider. Eventually I got the sequence to start.
Today I tried to take flats with the same setup. I had a manually inserted Ha filter so selected No Filter Wheel in the sequence but selected Ha in the filter column. It refused to start taking Ha flats because it could not connect to the filter wheel (which I do not possess).
I don’t understand why if I select No Telescope in the sequence, I then have to go down to another level and deselect the telescope options like meridian flip methods etc. This seems like a bug?
Likewise why is there no option to manually select filters when you tell the sequence that you have no filter wheel connected?

I had a similar issue two nights ago where SGPro was trying to use a non-existant filter wheel and also wanted to autofocus.

I had to redo my profile to solve the issue.

As the dialogs state, you have settings that require a telescope and a filter wheel set. Basically SGP doesn’t know what to do as those two things are in conflict.

Your second screenshot is highlighting this. You have filters selected with no filterwheel. SGP is telling you the target and the event that has the issue:

The Manual Filter Wheel was created for this purpose:


Thanks for solving the second problem. I was unaware that the manual filter wheel would solve that particular issue.
On the first issue, it is still not intuitive to me that if I select “No Telescope” in the sequence that it will not run unless I also turn off all the subsidiary telescope mount settings. I would expect that if I tell it that no telescope is connected that it should ignore any subsidiary settings for the mount. It took several of us working together to figure this one out.

Trevor, I suggest you read the online manual and understand the use of equipment profiles. Your use of a single profile for two separate sets of equipment is the root cause of your problems. In the past I also had problems like this because I did not spend the time to read the manual. By using your SCT/iOptron mount profile for the portable setup you’re inadvertently commanding SGP to do two separate and contradictory operations: perform a meridian flip, but do it without a mount. You can argue that SGP should be smart enough to automatically turn off the meridian flip setting, but changing one or more settings automatically in hidden (non-visible) areas of the interface will cause a lot of confusion among beginners.

In future I recommend you use two different profiles for your two different use cases, and then create new sequences using the appropriate profile. Or you can apply a different profile to an existing sequence by clicking “file” in the upper left menu, and in the dropdown choose “apply profile to sequence”.

Thanks for the helpful suggestions. I had tried New Sequence as well as New with Profile but when you have only one equipment profile set up they amount to the same thing. Clearly I need to create a separate profile with everything turned off except the camera.
Perhaps it would be useful to make the warning about subsidiary telescope settings one you can choose to ignore rather than bringing the sequence to a full stop. This seems to be the case in other parts of the software.