SGP ver 3.2.0.613 and ASI2600MM offset control

I am trying test captures and dark frames with a new ASI2600MM camera with all the new drivers from ASI: V6.5.16.3, and ASI windows driver V3.16 and ASCOM 6.5.1 platform.

In the fits header, the gain setting is included, however no offset. Why not?

In the camera controls, the gain settings range from 0 to 100, not the maximum 450 specified by ASI. In Sharpcap, I am able to adjust the gain from 0 to well over 100. The gain setting does appear in the Sharpcap fits header, no offset.

In the “Event Settings” dialog box for the SGP sequence, “Event Gain” is present, “Event Offset is NA”, why?

In the ASI driver dialog box that pops up under SGP camera settings, I can adjust gain (0 to 100), and offset, and USB limit.

In addition, in the file naming code in the sequencer, I have %ft%tn_%el_%bi_%su_%04_%cg_%co.

The camera gain is appearing in the filename, the offset however is not. Why?

One additional note, I tested changing the offset value with the camera settings dialog. The results appear to reflect this does work in test frames.

Anybody feedback is appreciated (aside from try N.I.N.A. that will occur).

@starmen5

You will need to upgrade to SGP v4.x to get support for ASCOM 6.5 SP1, which enables access to a CMOS camera’s offset values if the ASI camera driver has also been updated to support offsets under ASCOM 6.5 SP1.

Charlie

I have the same setup as starmen5:
ASI 2600 MC Pro, ASCOM Platform 6.5 SP1 , ZWO ASCOM Driver Version 6.5.1.3 and SGP Pro Beta 4.0.0.657 (64bit)

Fact is:
SGP Pro 4.0.0.657 doesn’t solve the Offset issue. The result is the same as in SGP Pro 3.2.
In the “Event Settings” dialog box for the SGP sequence, still “Event Offset is NA”, why?

In the fits header, the offset setting is not included. Why not?

In addition, in the file naming code in the sequencer, I have %co included, however the offset doesn’t appear in the file name. Why?

SGP Prov4 still doesn’t store the Offset value, not in events setting, not in fits header, not in the file name.

Please fix this issue.

Camera driver also has to support the Offset. Can you attach a SGP Log where you’ve attached the camera?

Jared