SGP4: Issue with switches, Pegas. Astr. Power Box Advanced


First of all, many thanks to the developers for their effort s on the new version 4.
Looks great!

However, there is one thing which is a little strange. I do not understand this switches tab for the profile. And yes, there are some issues related to switches. I use a Pegasus Astro Powerbox Advanced. I can only use SGP Pro ( when my PC is connected to the powerbox. If this is not the case (for example, when I use SGP without equipment, e.g. for setting up sequences), the screen fills up with error messages on connection issues because the power box cannot be connected. See attached screen shot.

How can this be solved?

Thank you very much, and all the best

Dear all,

I still have this issue. The problem is un fortunately stil not solved.
I updated to the new 64bit version. I also have the latest ASCOM version on my Win10 PC. Any idea how to solve this?

This error does not appear when I use the last SGP 3 version.

It would be good to solve this. The problem is not there when the power box is connected. But when I shoots darks or when I use SGP for session planning, it is usually not connected to the powerbox because the scopes (with fixed powerbox) are stored in a different room.

Would be great to get some feedback.
Thank you very much,

You need to update your UBP Drivers and ASCOM driver. It has been addressed there. You don’t have this issue in SGP3.2 as 3.2 does not support switches.

Thank you,

Hi Jared. Perfect! It worked. Thanks for your help.

All the best Jan