SGPro PlateSolve2 directory locations not retained

Useful Info

OS: Microsoft Windows 10 Pro
.NET: 4.8


I have recently rebuilt my imaging computer and ended up with a fresh install of SGP which I updated to 390 before I actually used it.

While configuring PlateSolve2, I found that the catalog directory locations as not retained, and so SGP cannot successfully solve using PlateSove2. This is likely only an issue for those of us who did a fresh install on a very recent beta.

Here is a workaround:
In C:\Users<username>\AppData\Local\SequenceGenerator, there is another copy of PlateSovle2.exe. Execute this copy and set the catalog directory locations. SGP will now be able to solve with PlateSolve2 successfully.

Steps to Reproduce this Issue
Step 1: Open the Plate Solve tab in Control Panel
Step 2: Select PlateSolve2 as the Plate Solving Interface
Step 3: Click the Settings button
Step 4: In the PlateSolve 2.29 windows click File->Configure Catalog Directories
Step 5: In the resulting window, set your directies to whatever they should be (other than the default profile locations). Note the “Status OK” for each directory
Step 6: Close the Configure PlateSolve Catalog Directories windows
Step 7: Close the Plate Solve application.
Step 8: Repeat Steps 3 and 4 and see that the directories are not set to what you just set them to.
Step 9 (Optional): Try a plate solve and get the error informing you that the APM directory cannot be found.


Thx for the report. I don’t have an explanation for this behavior, nor am I able to reproduce it. Changes to catalog location that I make when launching PS2 from within SGPro do seem to stick.

Yes. I believe it is related to the fresh install and lack of a SequenceGenerator directory in my local profile. Once I have set it (as described in the workaround) it seems to work fine from within SGP. Maybe just a ghost bug.

Could it be related to having 2 platesolve2.exe copies, one in Programs and one in the profile?

Maybe I am misunderstanding. If you launched PS2 from within SGPro, the Sequence Generator folder would be present in the local profile.

Sorry for the miscommunications; let me try again.

The local profile SequenceGenerator directory does exist once I run SGP for the first time. In this case, it is a brand new directory and does not yet contain a populated PlateSolve2.ini file.

I did a brand new fresh install of Windows 10 on a 3 year old NUC that I had been using for another purpose and wanted to try out with a Pegasus UPB2. I downloaded the latest SGP beta (375 at the time) and installed it, but didn’t really get everything else up and working before the 390 version came out. I upgraded to that and started building a profile. As part of that, I set up PlateSolve2:

  • From the “Control Panel->PlateSolving” tab, I chose PlateSolve2, clicked the “Settings” button and the PlateSolve2 application started (as it should).
  • I clicked"File->Configure Catalog Directories" in that application and changed the default locations to the directories that my catalogs live in, then closed the PlateSolve2 application.
  • I tried a solve on an existing FITS and it failed saying that it could not find the APM catalog.
  • I clicked the Control Panel->Plate Solving-> Settings button again, then File-> Configure PlateSolve Directories and found that the directories were back at the defaults instead of the location that I had set just a moment ago.

Workaround: In the local profile’s SequenceGenerator, there is a 2nd copy of PlateSolve2.exe ( the first one being in C:\Program Files (x86\Sequence Generator). If I start the profile copy directly from Explorer (outside of SGP) and set my catalog locations, they are retained, are visible from SGP and solves using PlateSolve2 from within SGP work correctly. My system is now working fine and is not in need of any fix, since I will not need to update the PlateSolve2 catalog directories. If this issue is not a figment of my imagination, new users who start with >= and have not already configured PS2 might have the same problem I did.

Could this be related to the changes done in beta 390 to solve the " Beta 388 - Extremely Slow to Launch Plate Solve 2 and ASTAP" issue?

I hope this makes some sense and does not further confuse the issue.

– Shane

Hmm, ok. I understand what you are saying, but I cannot explain it.

At this point, PlateSolve2.ini should exist in the local profile directory.

The copy of PlateSolve2.exe in Program Files is not ever used. The copy in the local profile is the same one that SGPro uses (and launches) when “Settings” is clicked.

Essentially, the workaround you noted above is literally the same exact sequence of actions that SGPro uses.

This is not related.

Well, heck! I don’t know. If I ever have to re-install from scratch again, I’ll see if it was all a figment of my imagination. Probably too long with no stars–just snow and clouds!

– Shane

1 Like

Ok… going to close this for now. Thx.