SGPro Planner doesn't show end icon, crashes

Useful Info
OS: Microsoft Windows 10 Pro
.NET: 4.7.2


When editing an existing event, the planner is inconsistent in showing the start & end icons. Setting new end times eventually causes an exception. Did the exact same thing in and it worked fine.

Steps to Reproduce this Issue

Edit an existing target settings, show planner.
Neither the start or end icon was displayed.
Set new start time - right of some position, no icon is displayed. Left of that position, start icon is displayed.
Set new end time - no icon, tried setting end time closer and closer to the right of the start time then SGP got an exception:

************** Exception Text **************
System.ArgumentOutOfRangeException: The added or subtracted value results in an un-representable DateTime.
Parameter name: value
at System.DateTime.AddTicks(Int64 value)
at System.DateTime.Add(Double value, Int32 scale)
at A_0, DateTime A_1, Boolean A_2)
at A_0, Nullable`1 A_1)
at og.rr()
at A_0, EventArgs A_1)
at System.Windows.Forms.DateTimePicker.OnValueChanged(EventArgs eventargs)
at System.Windows.Forms.DateTimePicker.set_Value(DateTime value)
at A_0, MouseEventArgs A_1)
at System.Windows.Forms.Control.OnMouseClick(MouseEventArgs e)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

[12/04/19 07:29:49.906][DEBUG] [Main Thread] End time has altitude lock, calculating start time for 20
[12/04/19 07:29:49.906][DEBUG] [Main Thread] ConvertTargetAltitudeToTime -> RefTime: 12/4/2019 5:23:00 AM; TargetAlt: 20; RA: 5; DEC 10; Lat: 40; Lon: -79; SiteElev: 0;
[12/04/19 07:29:49.909][DEBUG] [Main Thread] ConvertTargetAltitudeToTime -> Returned: SequenceGenerator.AltitudeToTimeData
[12/04/19 07:29:49.909][DEBUG] [Main Thread] Success. Found time 5:16 AM 12/4/2019 for altitude 20.0

To get logs: In SGPro click the Help->Open Log or if you are looking for logs from a previous session, Help->Open Log Folder and search by date.

Please post the sequence file you are using and provide a general lat / lon so we can reproduce this issue.

In the future, please do not paste logs in the post as they make threads difficult to follow and it introduces weird characters that make it hard for us to use them.

From what you posted above, I was able to recreate some semblance of the sequence you were using and create a user profile with the lat / lon you were using. Maybe I am misinterpreting your report, but I am unable to reproduce any of these issues.

Here is what the editor opens up with… both start and end markers are displayed:

I am not sure how to interpret this. What position are you referring to? Clicking left and right of the initial position sets the start marker exactly where clicked. Are you clicking on the graph or are you using the altitude / time controls on the target settings window?

Same as above. Unable to cause crash.

We must be doing something different… are you able to reproduce?

It happened on 2 computers but I am now not able to reporduce it.

It may be related to the time of day you are using the planning assistant.

I just had the same thing happen on 3.10544. The object was clearly in a decent position (see ST4 graph) so don’t know what will happen.