SGPRO must run in Win7 compatibility mode in Win 10 with EFW2

Hi Folks,

After upgrading to Win 10 on my 64-bit Pc I can only connect the Atik EFW2 filterwheel when I run SGPRO in Win7 compatibility mode. If I don’t do so, SGpro hangs when I try to connect my EFW2. My Atik camera works flawlessly in Win10.

At the moment I can work like this, but could someone shed light on the reason, because I need to activate the compatibility mode every time I install a new version of SGpro,

Clear skies,

I’m not sure. SGPro is fully compatible with windows 10. If you need to adjust the compatibility mode it is likely due to one of your drivers.

My efw2 and everything else works normally after migrating from 8.1 to 10 in current sgp and earlier ones.

I have some glitches with win10 itself - involving autohide of taskbar - but device connections are normal.

I posted a recent log for MetaGuide work - and it was on win10 and had efw2.


Ken, Frank,

Thanks for chiming in, I have tested my EFW2 on a different Win10 PC in the meantime and it works without compatibility mode. So something is not right on my astro PC, but I cannot see what could be wrong. I was using the latest ASCOM platform and EFW2 drivers on both machines. I am out of ideas how to troubleshoot such a driver problem,

Clear skies,

No issue here either with the efw2 and SGPro, windows 10. I would suggest re-installing drivers. I had a lot of issues when first getting my EFW2. Totally in related to SGPro.

Good luck

Hi folks,

I am still trying to figure out why do I need to start SGPRO in Compatibility mode to connect my EFW2 filterwheel in Win 10. This becomes now more important for plate solving, since I cannot connect my mount in SGPro via EQMOD in compatibility mode - it always tries to launch an new instance of EQMOD ( the running EQMOD instance is not in compatibility mode ) .

I think the root of the problem is that I have 64-but Win10 on my laptop. Can someone confirm that the EFW2 filterwheel works on his PC on a 64-bit Windows 10 configuration in Sgpro, without compatibility mode ?


Sorry Jonas I am a little confused.

Why are there two instances of eqmod trying to start?

I assume SGPRo is starting one, what app is starting the other?




No problems my side - run 64bit Win 10 and can control EFW2 via SGP …
just as I did on same laptop with Win 8.1. Installing Win 10 did not cause
me any problems.

Recently I saw problems with my Atik camera reporting incorrect temps (they
were jumping all over the place) while I was running a sequence in SGP. To
double check I connected to the camera in Atik’s ​capture programme
(‘Dawn’ I think it is) and all looked fine and worked fine with the temp
control in that programme. When I went back to SGP… all looked fine
there again with the temps. Just one of those glitches??? No Idea!

So if you are willing to try ‘anything’…why not see first if you can
control the filter wheel through Atik’s own software - and take it from

Just an idea…

Hi Rodney,

Thanks for chiming in. The first instance of EQASCOM is started by PHD2 - running without compatibility mode. Normally I can connect to this instance from SGPRO, but in compatibility mode SGPRO runs in a protected memory area I suppose, so he “doesn’t see” that EQASCOM is already running…


Hi Kinch,

Thanks for the tip, I will do a test with Dawn first and I will see after how to continue,


AHH yes ok . I moved my scope to a remote location and cannot test windows
10 anymore the PC that runs scope is still running windows 8… But yes this
does present a problem.

Do you have the new version of PHD and SGPro, where you are able to lauch
PHD from SGPro. Just a thought that maybe since SGPro is launch in comp
mode the PHD will also be launched with the same protected area.

If i get to head up to the scope I will try this, I have no plans in the
near future to head up there but i will try and keep it in mind and test it.

Sorry I couldn’t help any further

Hi mates,

Just to report back: PROBLEM SOLVED. It was completely unrelated to SGPro, but here it goes: I have downloaded and installed the latest version of Atik Artemis Capture. After installing the provided drivers in this package, my EFW2 works fine in Win 10 without compatibility mode !! Heureka !

Clear skies,