SGPro reports not receiving sidereal time from the Mount and PHD Guiding only works on one side of the meridian

I have an SBIG 16803 with the STX-Guider. The connection to the telescope, a Paramount MX+ is via the Ascom Telescope Driver for The Sky.
This is a screen shot of the settings.
Ascom Telescope driver for The SkyX
You will notice that I have ticked “Can Get Pointing State”
However I have been error messages from SGPro to the effect that the sidereal time cannot be obtained from from the Software Bisque Telescope…“Value cannot be null.” The error message also states that a meridian flip cannot therefore be performed.
Tonight when I started the sequence, all went very well until it got to guiding, whence the guide star was lost. It was pretty clear from looking at the PHD Guiding graph that the guiding signals in Dec were in the wrong direction, which is of course a positive feedback loop and drives the star further away. I restarted this several times, always with the same result. Here are two of the auto guiding charts:

I figured that when I was able to do a meridian flip, that the guiding would be OK and so it proved. As soon as I made the meridian flip, from The SkyX, the guiding worked perfectly. It seems that PHD Guiding is confused about which side of the pier the OTA is on and when it is on the west side, the direction of the Dec corrections is incorrect, which leads to a complete failure of the guiding.

I presume these two issues are related. Do you have any idea what I need to do to get the correct information flowing from the Mount to SGPro and PHD Guiding, so the captures can be made successfully with the OTA on both sides of the pier?

Here is a DropBox link to the logfile:


Your sincerely,
Niall MacNeill
Wattle Flat, NSW, Australia

Sounds like both SGP and PHD2 can’t determine the side of pier and maybe your mount can’t either?

For the SGP issue the Sidereal Time property must be implemented in ASCOM:

I’m guessing it’s there somewhere or there is some way to enable it. I’m not familiar with TheSky though. We do have lots of other users that have Paramounts so I’m assuming this is just a setting somewhere that needs toggled or maybe TheSky got into a weird state and needs to be restarted. Not completely sure.


I think so. I was able to guide without issue using the auto-guider Add-on in the The SkyX, which I presume means it knows which side of the pier it is pointing.
I will try again at the next opportunity with the OTA on the west side of the pier and see if the issue is repeated.
Should I contact ASCOM or Software Bisque about this?
Thanks Niall

Whomever makes the ASCOM driver. I’m assuming that is Software Bisque. But at the same time I know others are using it successfully so guessing it may just be a configuration problem.


I wrote an ASCOM driver for TheSky but handed it over to them about 2012. It implemented sidereal time using the PC system clock and logs the value to the driver log.

They seem to have changed it sinde then because the version is different.

Thanks Chris. It seems logical that something like that has occurred.
Firstly I am surprised that those with Paramount Mounts using SGPro and I am sure there are many, have not had this problem and reported it. Secondly can you suggest the best way of getting this fixed? Do you think the PHD Guiding issue has the same root cause?
Cheers, Niall

You need to contact SB. They could easily have changed their mount external interface. Sidereal time and Pier side are separate properties and may not be related.

If you do contact them make sure they know you are in Australia. It’s not unheard of that mount functions don’t work correctly in the Southern Hemisphere.

I have made a forum post on the SB site. Life wasn’t meant to be easy that’s for sure! Ugh

I made contact with Software Bisque and discussed the issues on their forum. The first suggestion was to run TheSKyX Pro in Admin mode. This apparently opens it up to sending details to other software programs such as SGPro. Well it seems to have worked. :slight_smile:
I no longer received error messages from SGPro saying it can’t get “sidereal time” information from TheSkyX which was good news. When I went to the PHD2 guiding logs it seems that it now has information about RE/Dec pointing, Hour Angle and on which side of the pier the OTA was located. I checked that the side of pier information was correct and it was. Clearly TheSkyX is now able to communicate with SGPRo and thence to PHD2 Guiding on the pointing state of the OTA. That is a win.

So I went to SGPro and with the OTA on the West side of the pier, where I knew the guiding didn’t work before, I tried running a Sequence. The guiding still didn’t work. The corrections in Dec were still going in the wrong direction. However again it worked when the OTA was on the East side of the pier. So I thought perhaps since the original calibration was done when PHD2 didn’t know which side of the pier the calibration data was acquired with, that perhaps a recalibration with the correct pointing might solve my problem.
I went back to the West side again I recalibrated PHD2 and it was able to guide OK. I then went over again to the East pier, where it had worked previously but the Dec corrections were now in the wrong direction. I recalibrated once again and the guiding worked. In both cases it was clear from the logs that PHD2 knew which side of the pier the OTA was on, so I don’t understand why it wouldn’t have reversed the Dec correction directions automatically.

As you know there is a tick box in PHD2 to “Reverse Dec Output after Meridian Flip”, which is unticked. My understanding is that if I have enabled pulse guiding that should be unticked. Can you advise whether I need to have this box checked for PHD Guiding to work correctly?

Here is a link to the various log files for both SGPro and PHD2 Guiding.

Thanks & regards, Niall

I believe that should be unticked if using pulse guideing…but at the same time it could be dependent on the driver as well. If you’re finding that Dec is moving in the wrong direction after a flip then it’s probably a good idea to untick that.


I have had confirmation that the tick box, needs to be ticked. Having done that the guiding appears to be working on both sides of the Meridian. :smiley: