Sky Safari Android

Has anyone successfully connected Sky Safari Plus for Android to SGP? I see iPad versions connected on here, but newest Android version doesn’t seem to see the SGP TCP/IP link. I am using local WiFi, POTHub with an iOptron ZEQ25. All else seems to work fine.

I’ve used it with SkySafari 1.8.5.


I just double checked this with my phone and a tablet. Still working well.

I would recommend double checking your settings in the android device. For the telescope in Sky Safari you need to select the “Meade LX-200 GPS” no matter what you’re actually connecting to. Then just enable the option to for external control in SGP and enter the IP or your hostname in Sky Safari.

I recommend leaving off the “Set Time and Location” option in Sky Safari. Also don’t use the “auto detect SkyFi” option either.


Yes Roodyj I use skysafari 4 Pro via a local Wi-Fi access point with a nexus 7 Tablet.
It works fine but there currently is a screen lag with version 2.3 of SGP. but this will be rectified in 2.4.

It has already been addressed in the 2.4 beta. SkySafari connections now poll the hardware real time…so be careful not to over extend your hardware as there is no throttling through SGP. This can lead to potentially bad results for both SGP and SkySafari. However most good hardware should be able to handle being queried at the Sky Safari max (10/second) but less “robust” hardware will have issues with that.


Hi Group and apologies Roodyj for jumping in here.
Back in September when I first started working with SGPro, I thought this was a neat feature and purchased SkySafari Pro. But no love. This thread re-inspired me to try again. And again I get “…can’t make a wireless network connection to the scope…” when I hit the “connect” button in SSP.

  1. Win 8.1 OS
  2. SGP RC1
  3. 12"LX200 Classic mounted on a Mitty wedge
  4. IP Address from SGPro: entered into SSP
  5. Port from SGPro: 4030 entered into SSP
  6. Scope Type in SSP: Meade LX-200 gps
  7. Mount Type in SSP: Equat. GoTo (fork)
  8. Auto-Detect SkyFi: OFF
  9. Set Time and Location: OFF

Two thoughts here:

  1. The venerable classic scope simply does not work with SSP, or …
  2. I’m simply missing a key step.

Any thoughts?

No problem on your input, niteman. Your experience is about what mine
has been. I am also using Win 8.1 OS, and indeed that may be the
problem. I have tried SGP and Sky Safari with another Win 7 Pro laptop,
and it seems to work. Just some issues on disconnecting at times, but
the reconnect is OK.

I am using the Sky Safari Plus V4 that I just purchased.


Hi Roodyj and Group,

My device is an IPad (vs. Android), and my SkySafari Pro (SSP) is v3.8.1.

  1. As long as I am at the home computer and select “Telescope Simulator for.NET” for the equipment telescope in SGPro, then SSP (on my IPad) can connect to this simulator, align and move the simulated scope around. Note that the home computer (Win 7) and adjacent router are the hub for my home network.

  2. When I do the same thing at the observatory computer (Win 8.1), the IPad SSP does not recognize the “Telescope Simulator for.NET” setting in SGPro. This is the identical behavior as when I select the Meade Classic in SGPro (at the observatory).

  3. While I did not explore this beyond noting it, I got two different IP addresses: “” at the observatory and “…1.16” at the home (successful) computer.

  4. Lastly, the home computer has a specific wireless connection, call it XXXXXX. I’ve added an extender to get WiFi out to the observatory. This extender generates a modified wireless connection in this form XXXXXX_EXT. This is the WiFi connection that the observatory computer sees, and also the WiFi connection that the IPad sees when it’s in the observatory. Other than the SSP issue, all works just fine.
    But my suspicion is that it screws up the communication between SSP and SGPro in the observatory…or there’s an issue with Win 8.1 not allowing access(?).

Sorry for the long wind. Any thoughts on this?