Slew Failures


Tonight SGP would not slew my mount (EQ6) anywhere. Plate solving worked fine - the mount just would not be budged.

I always connect to the mount via Celestron Scope Driver (which has worked perfectly for a year and is what I would always use) . As this didn’t work I tried selecting the Celestron Telescope Driver instead. This worked and the mount slewed to my target. The problem is, this won’t allow me to connect to PHD [I get a ‘driver does not support pulse guiding error’. I’m connecting the mount to the laptop with an RS232 to USB kit]

I was using the last version of SGP 2.3 release - but I saw that this is no longer supported. So I reluctantly upgraded to the last 2.4 release. I encountered the same problem.

Can anyone help please? Without being able to simply and quickly plate solve to a target CCD imaging becomes impossible !

As an aside, is anyone using the Celestron Telscope Driver with an EQ6 successfully together with PHD2 (and if so - how are you connecting?)

Thanks. Log files attached.

Banging head against wall several times


Sounds like you are running one application as admin and not the other. SGPro and PHD2 have to match.

Thanks for the speedy reply Ken. Have packed it all away as 5 hours frustration just about enough. But for the next night how would I ensure that I’m running both the same? Not sure how I would have (unwittingly) changed any settings though in any case…

It varies by OS, but they are all pretty similar. You will want to check both Sequence Generator.exe and PHD2.exe for this property to make sure they match. Here is Windows 8.1 after right clicking on the exe file and selecting “Properties”:

Thanks Ken I’ll try that to see if it resolves things

There is no need to run SGP as administrator, I’m surprised that this is suggested as a fix. Not running another application as administrator would be a good idea.

The Celestron drivers have not been designed or tested to work with Synta mounts. They partly work but the advanced features such as Park may not.

The original problem looks as if it’s because Park had been called previously. This is remembered and, because the driver thinks the mount is parked and so not tracking, slew commands are not allowed. The ASCOM specification does not allow Ra Dec slews when not tracking.

Calling Unpark may help to allow slews, then not trying to Park the mount.

Was that suggested? I only see the post where it was suggested they be the same…

Despite Chris’ rather aggressive response questioning our (my) competence, I will say that I agree with him. You should not need to do this. That said, some folks, for whatever reason, were never able to get Elbrus to work properly without running SGPro with administrative privileges. Once this happens, other processes that access the ASCOM server hub also need to do so with the same permission set.

This is almost always because they have installed Elbrus in a protected area.


It’s quite easy to just unlock the section of the registry or files area that an application needs access to.

A bit like having a mail box instead of leaving your front door open.

This can be done at install time, by the installer.

Thanks for the replies. I’ll have another go when I next get a clear night.

Chris - I did notice that the handset was reporting it had parked (when I did so) but what baffles me is that everything was shut down, powered off and restarted (several times). I followed the exact procedures I’ve always done without problem for well over a year now and it still wouldn’t slew.

I guess that’s astrophotography for you. Just when everything is working nicely, something comes along to frustrate you!!! Then you get to wait ages for clear skies again !!

Hello Chris,
I’m still having this same problem. The Celestron Telescope Driver will allow slews, although I can’t use PHD2 with that [I get a "Mount does not support the required pulseguide interface error]. On the other hand, the Celestron Scope Driver will connect with my eq6 and guide, but it won’t slew.

Any suggestions/advice welcome. I’m not sure how I call ‘unpark’. It’s strange as I never had a problem parking the mount then starting up again on the next imaging session.


Here is a screenshot of an error message I get, and I’ve also put tonight’s log file up:

If I moved back to the previous version of SGP I was using will my profiles (and more importantly sequences) be saved ok?


***** Stop Press *****

I have deleted all drivers from my laptop and just reinstalled the oldest one and it seems to have started obeying the slew commands again

Breathes a MIGHTY sigh of relief !!!

I don’t recognise the message box that you have posted. It doesn’t identify the application that generates it. It does say exactly what the problem is, the mount is parked and so slew is not allowed.

Not to worry, Chris, thanks for responding though.