Slow plate solves..unusable

I had to put up my DSLR because my astro camera went out. The scope is a Celestron HD Edge 11 inch at present without the focal reducer, focal length 2800 mm. I reset the pixels and scale in the camera settings. With attempting a plate solve an image is taken, but the plate solves with Plate solve 2 are so slow as to be unusable…one search takes 10 seconds. What is going on??


I suggest you try ASTAP for your plate solving. Large movement to it. Works really well and is lightning fast.

I installed it…did not find where to install the star catalogs?


In a message dated 4/11/2020 9:48:19 AM Pacific Standard Time, writes:

See if one of these links helps:

By installing the ASTAP database it goes automatic to the correct directory (same as program). Just download the G17 stardatabase and install it.


All links and Instructions:

Then select ASTAP as solver in the SGP menu.


Thank you for your instructions on the installation. I too have been experiencing problems with PlateSolve 2.29 since the last couple of updates of SGP and have downloaded and installed your software. I downloaded the 64bit version which was what I needed. My question is that the installer put the executable in the “programs” folder rather than the “programs (x86)” folder where PlateSolve 2 is located. I added the G17 database to the folder “programs” so it would be in the same location as the executable. But I have not tried using it in SGP yet. I’m wondering if it should be moved to the x86 folder to make it run correctly? I have tried running the program from the desktop icon and loading an image and solving and it fails to solve any FITS files I’ve loaded and they do have the appropriate header information including RA and DEC of the object. Any help would be much appreciated.



The location of ASTAP doesn’t matter. The 64 bit version runs faster then the 32 bit version so the 64 bit version is the one you should keep.

Solving should be reliable. In case solving fails, this is a checklist:

Checklist for solving:

  • At least 30 stars are visible.

  • Reasonable round stars.

  • Image dimensions at least 1280x960 pixels.

  • An approximate position for a spiral search is specified correctly. (unless you do a 180 degrees search)

  • Image is not stretched or heavily photo-shopped.

  • Correct image height in degrees specified within 5% accuracy. (Check focal length, sensor size settings or try FOV=auto once)

It is good to test solving first in ASTAP. If the position in the header is available, then very likely the image dimensions in degrees are also available. But they could be wrong. What you could try in ASTAP is to call up the stack menu (CTRL+A), go to tab alignment tab ALIGNMENT. Then have a look to the value “Image field height” in degrees. That should match. what you expect. Then try to select the value AUTO. Then hit the solve button. It will try all image height values till one gives a solution. If the resulting image height in degrees is very different then the orginal value your pixel size settings in SGP are wrong.

You could also upload the image to and see what image height is reported there.

If it still not work, report here the link to the upload file in and I will have a look.


I installed ASTAP and tried to run it and got an error message that the star catalogs were not present. I opened the program but could not find where to show the sub-directories. Can you tell me how to install the star catalogs?

Plate solves with PS2 using a different scale were as fast as usual last night.


In a message dated 4/15/2020 10:29:50 AM Pacific Standard Time, writes:

You have to install the program in two steps. An installer for the program and a seperate installer for the star database. They both are installed default in c:\program files\astap

The star database can be downloaded from here:

Just download and execute the installer.


Thanks for the quick response and I will investigate further and get back to you.


None of the mirrors are working to download the database.


In a message dated 4/15/2020 11:23:44 AM Pacific Standard Time, writes:

I was able to download it with a different browser.