Starlight Xpress Camera ASCOM driver crash

Hi all,

I finally upgraded to a CCD and during last nights clear skies I got to use it in anger. It all worked fairly well but during the night the camera became unresponsive, it was still in this state when I got up this morning.

It looks to me that the driver has creashed as the camera was still alive this morning, looking back I should have checked Windows device manager to see if the windows driver was also crashed.

A seperate issue is that SG Pro was complaining the image didn’t download in time. I have increase the download times in the equipment profile and disabled high-speed downloads this morning.

I’ve attached the SG Pro debug logs: (120.0 KB)

Thanks in advance for any ideas.

Looking through the log, this seems to be where it goes pete tong:

[10/27/17 00:47:23.324][DEBUG] [CP Update Thread] ASCOM Camera: Error in GetCoolerTemp. : CheckDotNetExceptions ASCOM.sxCamera.Imaging0.Camera CCDTemperature Get System.Exception: WriteFile write error=121 (The semaphore timeout period has expired)) numBytesToWrite=8 numBytesWritten=0. (See Inner Exception for details) (System.Exception: WriteFile write error=121 (The semaphore timeout period has expired)) numBytesToWrite=8 numBytesWritten=0.)
at ASCOM.DriverAccess.MemberFactory.CheckDotNetExceptions(String memberName, Exception e) in c:\ASCOM Build\Export\ASCOM.DriverAccess\MemberFactory.cs:line 630
at ASCOM.DriverAccess.MemberFactory.GetTargetInvocationExceptionHandler(String memberName, Exception e) in c:\ASCOM Build\Export\ASCOM.DriverAccess\MemberFactory.cs:line 664
at ASCOM.DriverAccess.MemberFactory.CallMember(Int32 memberCode, String memberName, Type parameterTypes, Object parms) in c:\ASCOM Build\Export\ASCOM.DriverAccess\MemberFactory.cs:line 288
at ASCOM.DriverAccess.Camera.get_CCDTemperature() in c:\ASCOM Build\Export\ASCOM.DriverAccess\Camera.cs:line 128
at A_0)

Interestingly, before this point the GetCoolerTemp isn’t mentioned. I’m wondering why it would appear over an hour into the logs.

I’ve had image download hangs with my SX in two situations:

  1. I was using Frame and Focus, tried to stop it, and then tried to start it again before the camera operation had finished. Basically, don’t press buttons until the download progress bar turns off.

  2. When I added a Lodestar guider to my system, I got download hangs. The remedy for this may be to connect to the imaging cam via ASCOM and the Lodestar via the native driver. Since doing that, I haven’t seen any hangs.

It’s also possible that I’ve had other download hangs. I’ve had the camera for three years, and once in a long while I find things went wrong during the night for reasons I can’t figure out. But that’s very rare.


I had a flick through an earlier log and this failure had happened also so this is at least twice in a single night.

From the log it seems that either the driver has gotten stuck in a loop or the camera has stopped responding, judging by the mention of a timeout in the error output.

I’d love to know why this call suddenly appears in the sgpro log without being mentioned previously.

I guess the onus is on me to figure out which side the problem lies on. I’m thinking that if i can still see the camera in Windows device manager then it might be pointing at the Ascom driver but if the device isn’t there then something has gone wrong at the camera side.

I do accept that much of this is guesswork.

UPDATE: After plenty of support from Starlight Xpress this looks to be caused by powering the CCD & mount off a single DC PSU.

The mount motors seem to have been putting noise into the grounds which cause communication issues for the camera.

I powered the camera last night using a seperate PSU and it ran for 13 hours without error while capturing lots of data for me :slight_smile:

ANOTHER UPDATE: The problem has continued, allbeit much more randomly.

The camera is awaiting collection by DHL to be returned to SX as faulty.

peje1873 I know it’s been quite a while, but how did this end up resolving? i have the trius 694 pro, and it does hang occasionally in a similar fashion

Hi, unfortunately I didn’t solve this problem. I switched to the equivalent Atik camera and the problem didn’t occur again.