Starlight xpress ccd not shown on list

Does the SGP support the starlight xpress trius h-674 mono. I tried downloading the latest drivers for it but I get the following message Error getting dialog retrieving the com class factory for component with clisd. Not sure what that means any help be greatfull.


Have you got the latest version of ASCOM installed ???

As well as the Camera’s drivers, did you also install ASCOM drivers for it ???

If ASCOM drivers are not installed for a camera they wont show up to select as SGP uses ASCOM
for equipment connection.

This link looks like it might be useful:


That’s the post I put on SGL myself, the link given (daddog.cmascom/sxcamera) I went on to and down loaded the zip file, opened it and it came up with message saying :- A previous version of this driver that cannot be automatically be removed was detected. The trouble I had a look in windows settings- apps to uninstall the previous version, I cannot find the driver anywhere.Any ideas would be gfeatfull.


Sorry Diesel, how ironic is that ?

I wish I could help more but cant.

On the flip side, this guy seems to know what he’s talking about (at the site you show in your previous post) so maybe he may be able to shed light on the issue you have of the installer reporting a previously installed driver…Got to be worth a shot ?

Good Luck

Hello again,
So I have gone to the site you mentioned above and ran the installer on my system which is Win 7 64bit, I was curious to see if it reported a previously installed driver and/or to see if it would show up in SGP and Windows uninstall thingy.

See image I have attached:

Yes, it is selectable in SGP marked as Starlight Xpress H674 in the camera dropdown, the setup box is coming up too as you’ll see in the pic.

Yes, it is showing in Windows uninstaller thingy marked as ‘ASCOM SX Camera Driver V6.2.1.17140’

Now seeing if I can find where it’s been installed to…

Please Wait !


This is what I have found:

C:\Program Files (x86)\Common Files\ASCOM\Camera\sxCamera\

Loads of files here !


C:\Program Files (x86)\Common Files\ASCOM\Uninstall\Camera\sxASCOM\

There is an uninstaller here and it did completely remove everything from the above location and it no longer shows in SGP or windows uninstall thingy.

Cant find anything else !

Have a look for the above Uninstaller file, run it & see what happens Diesel


Have you tried uninstalling the driver from Device Manager?

Basically, turn on the camera, wait for it to pop up in Device Manager, then select “properties” and then uninstall driver.

I had to do that with my QSI when the driver started to act up.

Once gone (and after reboot) you should be able to install the new driver.