Starter for 10 - using a NUC as a telescope hub?

I was thinking of buying an old office DELL desktop, loaded with Win 7-64 bit for running my observatory, rather than fiddle with Bootcamp and my Macbook Pro.

I came across NUC - these diminutive PC’s are designed to stick to the back of TV’s.

I was wondering - these come with wifi, ethernet, USB and HDMI - has anyone tried using one of these for a telescope hub and running it remotely over ethernet? I would load the software up on it and then run it blind - without keyboard or mouse, operating remotely. It could even fit on the tripod accessory tray. This could be a potentially neat solution to a lot of concerns.

I once tried to use a Netbook - but found its USB ports were not operationally fast enough to do image download from a Starlight Express H18. I wonder if it is worth a try anyway, they are only about £100.

Food for thought… I would be interested if anyone has got this to work.

Hi Chris,

I been using a NUC for a while as my main scope PC, have the i5, D54250WYKH to be more precise as this allows the use of a 2.5" laptop drive. I added a wireless/bluetooth cards, 1tb hybrid drive and 8gb of ram.

It sits in a box along with other control equipment that I place next to the portable pier when I setup. I connect to it using wireless and RDP, allowing 3 screen access to it.

Had no problems with speed CPU or USB, it works brilliantly,

Never seen one at a £100, these are barebone systems so need to add memory and a mSATA drive at the minimum - looking a nearer £500 for an i5 with decent amount of storage and wireless.

This is my main system and run everything and it sits next to scope so no long USB runs, just power.

Sits is this box

There’s an NUC on ebuyer for £99.99

BUT you also need:
Memory - £26 for 4Gb
a HD or SSD - £42 for 120G SSD
an Operating system - £68 for W7 64.
= £236
That’s a pretty low end system and considerably more than £100.

You could get a desktop PC for around £168, including everything, or a cheap laptop for about the same.

My impression is that these tiny PCs are nice but you pay a premium for small size.


That is the base model, Celeron CPU and only 3 USB ports.

You do pay a premium for the size, in my case a wanted something that could sit next to the pier, small footprint and and on par performance wise to a desktop, as don’t need a screen or keyboard this was a perfect fit.

Having spent a lot of the hard earned cash on decent equipment spending £500 on good kit to run everything on seems reasonable.

You might check out Computer Refrub too. They take older PCs, clean them up, reformat/reload, and resell them. You can get a pretty good deal on those small desktop models like this:

Or, what I am currently working on is using Linux on a Raspberry Pi running the INDI to ASCOM drivers (it makes the Linux INDI server available to ASCOM in Windows) as the remote for SGP. I don’t have it all working yet, but I do think I will soon. Then the INDI server runs on the Raspberry Pi and handles all the gear connections and SGP runs inside on my desktop. Then for about $70 you get a credit card sized remote PC to run the gear.

Can you say more about INDI to ASCOM please.


My head is spinning - I have enough fruit with Apple and Tangerine (if you go back that far)

I think I saw Software Bisque prototyping something similar - they had a tiny PC in a clear box integrated with a mount - I assume to allow remote operation with a dumb server.

I go back that far, one I don’t remember was the Lemon :slight_smile: I do remember the Apricot though.

INDI always has a server that either runs local or remote so its architecture supports running the gear on one box and accessing it remotely from a client on another. INDI to ASCOM uses wINDI with ASCOM drivers that talk to the INDI server. So you can run ASCOM on the client and INDI on the server.

There is also the similar Gigabyte Brix. Don;t have one but have thought about it.


Can get i7 quad core versions of the Brix- nice box though reports of running hot. More power than you need though, could really get away with an i3 for running all the control software. I got the i5 version as intend to run the the whole obs from it, roof, cloud sensors and allsky camera.

I picked up one of these

May try to run my obs including SGP off of it. I think it should be able to handle it. I have other plans for it so this would me more of a “will it work” experiment.

My STL-11000 may have issues as this has USB3.


I had a Grundy Business Machines ‘NewBrain’.

I feel like I need another one to cope with the span of operating system technology that I have missed by only developing standalone microcontroller systems, albeit some using Transputers. A project for retirement I think.

@trevorn thanks for that - I thought I would try RDP with my laptop a 2.5GHz Core I5 Macbook Pro (bootcamp).

RDP runs well on my iMac, with Win7-64 running on the bootcamp partition of the macbook- even with TSX and its planetarium, if you reduce the FPS rate. The iPad version of RDP is ok for monitoring, but little else.

I am definitely going to go the NUC route rather than an old used PC. I will also be able to dispense with my USB over Cat 5 cable extender and for those times I go to a dark field site, the NUC can sit underneath the tripod with the batteries and I can have a completely wireless system back to the car. That seems to be the best way to avoid the potential trip hazard. I think the major difference, at the same processor speed, between the i5 and i3 is the i5 has the potential to over-clock. If the I3 is sufficient, I’ll probably go that route and save the power. If it wasn’t for the WiFi, I would house it in my powder coated steel electronics interface box.

One question though, I can see you only need to power up the NUC to be able to log on, but RDP does not allow you to shutdown remotely. How do you shut down the NUC cleanly? I always understood it was damaging to turn windows off with the power switch. Is there another way? My second question is, can you connect with RDP over an adhoc network, or only through an Internet connection. A did a web search but after an hour, could not find a solution. The network is connected - I can see the traffic when I try and connect with RDP- but it thinks it is not enabled on the host.

Hi Chris,

For poweroff and restart I have to CMD files with ‘Run as administrator’ enabled shortcuts on the desktop.

Each has a single line.

shutdown /s /t 5

shutdown /r /t 5

The /t is time, default is 60sec

You can also run cmd.exe as administrator and type the same command in.

When I get the obs sorted I will hibernate it but that requires the psshutdown.exe from the sysinternals package.

Should be not problem connecting via a adhoc network, just need to know the IP address of the system your are connecting to and if you have windows firewall enabled on the host PC will need to add an exception for port 3389.

Remote desktop host is also only supported on the Pro and above versions of windows, any version has client capability.

Forgot, they run from 19v which will require a 12v - 19v laptop adapter for field work and may be better to skip the 2.5" hybrid drive option and go for a reasonable size mSATA to reduce power requirements.

Thanks for that Trevor - I am running Win 7 Pro and had enabled Remote Desktop in the firewall settings - I’ll go and look to the port settings. I like the trick of the .cmd files. I’ll note that for later.
The Intel NUC has a 12-19V range according to this thread. I’ll have to check the models are all the same.

update: I went into advanced firewall properties in win7pro and these ports were already identified and accepting input and output via public and private networks… it all works through my Airport wifi hub but not directly…Hmmmm

Looks like I can get an i3 1.7Ghz fully loaded for about GBP290.

That’s something I did not know, made the assumption that as the supplied power supply was 19v that was the required voltage, just done a quick test and powers up from 12v would need to make a new cable to fully test.

Can check if a firewall issue by disabling them temporally, I don’t run them here as have perimeter firewalls.

Never tried using an adhoc network, will have a play with a couple of laptops and see it can see a reason.

Had a play with adhoc network between a laptop and my surface tablet and that all works,

This was tested on win8.1, MS in their wisdom removed the GUI setup of a adhoc network so some faffing around on the command line with netsh but hopefully proves it should work when setup.

Don’t forget shutdown -r -f -t 5… It will force programs to close instead of waiting for a user response.

@Jared - for info there are still Intel NUC’s with core i3’s and just USB2.0 around - they are the ones being discontinued and discounted.