Startup/Resume/Shutdown logic issues

I have been running an unattended sequence over several nights in my ROR observatory, fitted with cloud and rain detectors. The 64-bit version has run without issue, until I tried something slightly different. I normally set all my sequences going when the conditions are good. On this occasion, it was still cloudy but the forecast said it would be clear at midnight. I opened the roof to cool the optics, connected all (camera started cooling) delayed the start time and started the sequence. The safety monitor was red at the time and I went to bed. In the morning, the roof had closed, there had been no exposures apart from a single plate solve frame, the equipment was still all connected and the camera was at ambient. The camera temperature warning dialog was on the screen, waiting for user input.

I am not certain what conditions prevailed through the night but I think the camera temperature dialog (presumably triggered on resume) stopped further action, including shutting the sequence down and disconnecting equipment etc.

This feels like a logic issue, more than a settings issue for several reasons:
a) the camera temperature warning is a point in time and should self-dismiss if the camera temperature is subsequently ok and
b) the dialog was on the screen but the camera was not trying to cool.

It would be really useful to be able to have SGP manage a night’s imaging without user intervention, irrespective of changing conditions.

Link to log file below.

The camera temperature warning dialog was on the screen, waiting for user input.

This was addressed in 4.0.0.680 that was released a couple weeks back.

Jared

Hmm, I’m running what i believe is the latest 64 bit. I ll reload it as it is not prompting for updates.

Hi Buzz, the log file in dropbox shows version 676 verses the latest release 680. Also I find that checking for updates in SGP gives me mixed results so I generally just go to Downloads – Sequence Generator Pro and manually download the new version.

CL

Thanks - looks like I got caught out by auto-update not triggering. I have downloaded the latest and will give it another go.