Support help required modules work then they don't


failed to connect ,failed to show temperature failed to show cooling

Link to Logs

Useful Info

OS: Microsoft Windows 10 Home
.NET: 4.8

What module? About what date/time did you have the issue?


The temperature for the cooler doesn’t show up it’ll show { na} but , the fan is spinning fast even after reboot , Frame and focus , focuser control 0 out and doesn’t connect but, sgp says it’s connected. I have a screen flicker while it’s trying to connect the telescope and it fails to connect “unhandled exception warning” and last night error connecting telescope to port 1 , it’s assigned port 3. I’ve replaced connector cable and another serial to usb adapter on its way thinking that might be why according to Ed Overstreet ,we both are using 3.1 now he’s puzzled . It connected at around 530pm est on the 19th and all was working according to sgp no errors and when I went back out to PA with" pole master " at 7pm est . I tried to get my mount to connect and it failed. I’ve got an abundance of logs dating from the 27th 2019 to the present . The final straw is when I get the external cable error . Everything is disconnected ,shut down and I go into the warmth and start calling people and posting my problem .

Not sure about this. Is the camera connected to a USB hub?

What about Frame and Focus?

Im not sure what this means.

There is no way SGPro can cause this… that said, it may “influence” the behavior by asking an ASCOM driver to do something that uses very low level hardware.

What day and time was this (approximately)? SGPro does not manage mount ports… that is coming from the ASCOM driver.

There are no logs attached that show this period.

I connect the main and guide camera straight to the computer , frame and focus hangs on downloading and I wait at least 2 min. before I use task manager to close the program and reboot and do it again after 5 min. {screen flicker} I just have never seen this behavior before with Sgp and yall wanted to know how it was acting. I understand THE WARNING but, the fact that I get these boxes telling me this and that isn’t sitting well after I had a sgp user set up my sequence section by section item by item over the phone for over 45 min. I’ve got all my logs but, don’t really know which one you want Ken. What about the AF not showing the steps for my filter or the cooler showing an NA when the fan is running fast on the camera?

I really don’t understand much of what you are asking. It seems like a stream of consciousness and I am having trouble deciphering. Let’s just deal with one thing at a time. Which one do you want to start with?

Sorry , I’m frustrated after countless hours days and nights setting up and getting everything connecting then when the stars come out nothing but, frustration over and over. I was out again tonight after working the problems in daylight. I open Sgp go to file: equipment manager checking what was supposed to be saved but, {some is } in every tab of equipment is like that . Connect equipment sometimes the dro autofocuser doesn’t connect and the telescope driver doesn’t want to connect and when it does connect it takes at the least 2 min. to connect . I could write a book on everything that disconnects . I’m really trying to explain this but, everything that can go wrong does. Let’s start with the telescope connecting 1st.

That’s fine. Also, because of all the problems you describe, I suspect that solving one issue here could clear up almost everything you are seeing. When we see issues like this that span across multiple pieces of gear, it is usually from a common element like a USB hub. Ultimately we need to see logs describing the issue. So for the mount… please reproduce the issue and send them over. We will take a look and go from there.

1 Like

Ken , I’m going to try again tonight , last night all connected except for the efw “message further installation required” . I reinstalled the driver and it still wouldn’t connect with it plugged into the camera back or the computer sgp kept giving me an error message. I didn’t check for updates right before I went out , I don’t know if that has anything to do with it. I downloaded the 3.1 version at least 3 different times and it still brings up the sgf. of a previous screen that I failed on instead of a new screen or reset , Please add that to the list of things . I’ll stop tonight once I attempt to connect and get the error message and send it . Error { Assembly manifest doesn’t match reference}

I took my computer back to factory settings hoping that would reinstall what had been removed or corrupted by an update and spent most of the day re-installing software and driver for imaging. When I downloaded sgp 3.1 all looked good , at first until I started to setup in equipment manager , it had in the profile box" Canon template, LRGB template and narrowband template". I don’t need these profiles . I had all but, the mount connect and I changed to generic hub and it connected . I tried a test to see if it would move the mount and a message box informed me to unpark the telescope and I did , I haven’t had the chance to get out at night to see it actually work , a BIG slow moving storm wed. and thurs… I’m working the problems Ken. I downloaded dropbox again so I can send the log the next time I’m out , it Dropbox wanted me to change the format that night that I attempted to send .“FINGERS CROSSED” this will ease my pain.

Closing due to inactivity. If this is still an issue, please send the requested information and “uncheck” this thread as solved.


You don’t need to clear equipment profiles to start from scratch. You can just make a new one (and delete the ones you no longer use).

Thank you Ken , I thought this might also be a problem . I’ve exhausted my knowledge Help me resolve the other issues Please .