Temp Comp and Starlight Focuser

OK, this is with the last version of 2.X but I suspect it is either all versions or maybe an issue with Starlight/Optec.

I decided to try continuous temp comp tonite thru the focuser SW and just have SGP focus as usual as well.

Can’t be done anymore, as it turns out. Both apparently cannot be connected at the same time (error if I try). Does not matter which is connected first, the other will fail to connect. Since I cannot run continuous temp comp w/o the Optec program addressing the focuser, that is now not possible to even do.

I am pretty sure I used to be able to do this, but it has been several years since I last did it. Don’t know what has changed, either SGP or the focuser SW/firmware.

FYI, when I connect the focuser via ethernet, both connect fine so this may be a USB limitation. The problem is that in the past (maybe they have fixed this), ethernet would always disconnect the focuser after about an hour or so.

So has SGP changed or do I talk to Optec?


I use an Optec Gemini focuser and I have used their TCF-Si focusers in the past. There is no problem having the Optec software and SGP connected to the focuser at the same time. This is my standard mode of operation. I use the Optec software to perform homing and to enable TC directly in the ASCOM driver. I then connect SGP to the focuser for the purpose of auto focusing. The Optec software runs along with SGP all night.

By the ASCOM standard, a focuser may not be moved by an external application when TC is enabled in the driver. SGP handles this by checking the the status of the focuser’s TC option before starting an AF run. If SGP sees that the focuser has TC enabled, SGP “remembers” that and then turns TC off; runs the AF routine; and turns TC back on.

There is a problem if you try to run the AF routine manually and the focuser TC is enabled. SGP is not managing the focuser’s TC when AF is run manually and a manual AF will fail since the focuser is not being moved.


The ASCOM temperature compensation is relative to the focuser position when TC is enabled and this means that it isn’t practical to do absolute moves when TC is on. You don’t know where you need to go.
The way to allow for this is for SGP to check the state of TC and if it’s enabled disable it, make the move and re enable it. For auto focus leave it disabled. AIUI SG has taken the easier option of disabling it Also with TC on the focus position will change as the temperature changes and this will make things tricky with getting focus offsets for different filters.

Something I wonder about is changing ASCOM so the focus motor position is always set as a function of the position commanded, the temperature and the temperature coefficient:

MotorPosition = Position + Temperature * TemperatureCoefficient

Position = MotorPosition - Temperature * TemperatureCoefficient

This is used all the time. Enabling temperature compensation causes the temperature to be monitored and the focuser adjusted. Moving is allowed with TC enabled.

I did implement this in a couple of focusers as an option but wasn’t in a position to test it and never heard if it worked. One was the current Moonlite DRO focuser controller - check the “Full Temperature Compensation” box. If you try this I will need driver logs.

I think both of the replies above missed my point. I know how the software works and is supposed to interact. I have used the systems in the past with both software (SGP and Starlight/Optec) running and connected at the same time. It always worked as it was supposed to and as you described. I knew that.

The problem is that neither software will connect if the other is already connected - it simply errors out with the following messages:

The first is the error in SGP if the Optec SW is connected, the second is the error in Optec SW if SGP is connected.

Windows 10 64 bit and BTW, this happens on two separate systems, one remote and the other at my home. Sure looks like a USB issue to me - as I said, it does not do this over ethernet when the focuserboss control box is connected that way - although the ethernet connection has always been flaky with the Optec SW - a separate issue.

Could be that USB is supposed to work that way but my recollection is that this problem is new.

Of course you can’t connect two applications to the same serial port at the same time. This is a serial port implemented with USB but that makes no difference.

That is what I figured except for one thing:

Myself and another experienced imager (20 years) both had it work before.

That is what I cannot figure out. The reason makes sense but it should never have worked at any time - but it did.


Only the ASCOM driver should connect to COM5; the application(s) should connect through ASCOM. Windows has NEVER, EVER allowed multiple apps to use a COM port simultaneously. You must have previously been accessing through the ASCOM driver.


I always wondered about the two programs controlling the focuser and I think chasmiller46 is right about both programs controlling the focuser via ASCOM. When I start FocusLynx I can see in the task manager that it automatically starts the ASCOM FocusLynx

I use both programs to control the focus, e.g I manage the TC with the FocusLynx and the Autofocus by SGP, this always worked with no problems and still does.

I am on 2.6.24 version and use the latest version 2.0.6 of FocusLynx.


If I am correct, that is the only way to access, or is that wrong? There is no separate ASCOM driver download that I am aware of and when you install the Focuslynx software, it also installs the drivers unless I am mistaken. FYI I am also fully updated on both the Focuslynx and the Focuserboss firmware.

OTOH, the only choice to connect within the Focuslynx SW is the com port (other than Ethernet) and the only choices within SGP are as shown. That implies SGP is using the ASCOM driver yet I still get the com port error above if I try to connect with SGP and Focuslynx is already connected.

If I am reading the post from uirabraham correctly, he is not seeing these errors, which was my previous experience, and the reason for my posts.

I would again repeat that nothing in my methods or hardware has changed except for a new PC and Windows 10 install. I would also repeat that this is showing up on two separate systems both with focuserboss systems and software but with different PCs, different motherboard manufacturers, etc.

So you are saying that you can connect with both Focuslynx and SGP and leave both running and get full readout and control with both? Please confirm that. If so, that is the way it used to work for me until recently. Why it no longer does is the question.


Although I have used multiple Optec products, I have not used the FocusLynx software. However, browsing the Optec web site, it looks like there is new firmware and all new ASCOM software. I’m willing to bet that Optec has implemented the FocusLynx software with ASCOM in the same way they implemented the TCF-Si and Gemini products; that is, multiple clients can simultaneously interface with the FocusLynx hardware via the Optec ASCOM driver via an Optec USB - serial cable. Also, make sure you have installed the very latest version of the ASCOM platform.

FocusLynx ASCOM


All drivers, operating systems, software, everything (including ASCOM) are current. Checked that long ago and just rechecked it anyway.


Sounds like its time for a call to Optec. They can remote into your system and take a look around.


Sorry for late reply…

Yes, that is correct, I use both SGP and the Focuslynx simultaneously. This works on my Laptop running Windows 7.
I can see the correct readings and control with both Focuslynx and SGP e.g I apply TC from within Focuslynx while the autofocus is on in SGP and I can move the focuser using either program


uriabraham wrote:

Yes, that is correct, I use both SGP and the Focuslynx simultaneously.
This works on my Laptop running Windows 7.

Makes me wonder if it is a Windows 10 thing…