Trying to connect to the Eagle to Control Switches?

The last 4.0 beta removed functionality where SGPro would attempt to find the Eagle device by itself (because it didn’t work well). In its place, we have added a settings dialog so you can tell SGPro where it is. You can get to it from the control panel’s “Switches” Tab:


Note: There is no “Connect” button and SGPro will continually auto connect. In parentheses after PrimaLuce Eagle you will see text that reads Not Found or Connected

Eagle settings:


We are going to change the wording on this dialog… it should indicate that you need to:

  • choose “SGPro is running on the Eagle device” to “SGPro and Eagle Manager are running on the same machine”. e.g. SGPro and Eagle Manager both running on the Eagle device - OR - SGPro and the Eagle Manager both running on a remote device (and Eagle Manager is connected to Eagle remotely).
  • If SGPro and Eagle manager are running on separate machines, choose the bottom option. e.g. Eagle Manager running on Eagle and SGPro running on a remote machine.

Note: I don’t think it’s possible to change the port location of the Eagle Manager Server (maybe?), but the default is 1380. If you are using the top option with port 1380, you shouldn’t need to make any changes.

I am running SGP v4.0.0.657 and the Eagle manager (Eagle software v3.5) both on an Eagle3Pro.

When I open up the control panel and choose settings for the Eagle, I choose the first radio button (SGPro is running on the Eagle device) and set Port to 1380, as per default (and the Eagle manual).

SGP, however, cannot find the Eagle, and (Not Found) persists in the Control Panel.

If I go to my browser and use teh commands set out in the Eagle manual, I can trigger on/off events for the power and USB ports on the eagle manually, so I know that the functionality is there and working, but I am unable to convince SGP to connect.

Any thoughts on what I might need to do?

Just bumping this. For the Eagle users out there, have any of you managed to get the switches functionality working? I am just trying to figure out whether this is a user error problem (usually the case, at least with me) or an SGP functionality problem (in which case I will park it, while the developers address it).

I confirm that I have the same issue with my Eagle3, software V3.5. I am however still on SGP, as the newer versions don’t seem to get along with my QHY camera (offset setting).

EDIT: I tried the 64bit version of and get the same result as described above - “PrimaLuce Eagle - (Not Found)”


Thanks much. I am assuming that the switches functionality with the Eagle is just not yet working in SGP. Hopefully a developer can confirm?