Tutorial or Instructions on how to install Astrometry.net for SGP

I have found installing/configuring Astrometry.net with SGP including Cygwin not so intuitive. I saw several SGP threads showing instructions about installing/configuring but I find them pretty cryptic and disorganized. It’s obvious it’s not as simple as typical software installation package for end users. Most of use here are end users of software. We are not IT specialists nor software developers. Getting SGP to work with ansvr should not be an abstruse exercise involving typing long, relentlessly unforgiving unix strings into windows computers.

I am having issues using Cygwin and I don’t yet want to describe what went wrong right now. I have 64 bits Windows 8.1 laptop and so far SGP works perfectly with all of my astro devices. Also USB 3.0 port from my new laptop works perfectly via my USB 2.0 powered hub. Auto focusing with different filters work great.

My next step is plate solving. I thought about buying Pinpoint simply because I read that it’s the easiest plate solver software to install and also reliable to run even though it costs $150. I have also read that Astrometry.net works very reliably only if the installation and setup works. I installed 64 bit version of Cygwin and so far my initial setup with ansvr did not work. Should I install 32 bit version of Cygwin instead in my 64 bit laptop?

Would it be possible to create a software installation package that would automatically install and configure everything to get SGP to work with Astrometry.net?



Sorry you are having trouble with the installation. You should uninstall that 64-bit cygwin and start again by following the instructions in this post to get cygwin & astrometry.net installed. Then, follow the instructions here to get ansvr updated to the latest version (0.13.) If you have any trouble, please do not hesitate to ask, we will help you get it going.

Please do not try typing any of those commands by hand … use copy/paste (select text with mouse, hit Ctrl-C to copy, hit Ctrl-V to paste)

Although it is possible to create an installer for astrometry.net+ansvr and I have done some looking into it, it is not really a priority for me at this time. Pinpoint may be an option for you if you are not comfortable with installing astrometry.net+ansvr. I have not used Pinpoint myself so I can’t really say whether or not it has the same capabilities as the astrometry.net solver.


I also posted this question at Cloudy Nights forum and someone answered one key missing item. The sub-directory “opt” is not there by default and he said I would have to manually create the “opt” sub-directory. Is this correct?

This is what he said:

You will need to create the “/opt” directory by typing the following in your Cygwin shell:

cd /
mkdir opt
cd opt
tar zxvf /tmp/ansvr-0.12.tar.gz -C ./

Also, it’s not so simple to uninstall Cygwin because it does not have an uninstaller. It does not show up in my “Program and Features”. I found a FAQ about uninstalling and it was pretty cryptic but I was able to do it.




If you use Chris’s pre-packaged cygwin bundle (the first link in my prior post), it will already have /opt, so manually creating it will not be necessary.

Also, the instructions you got from cloudy nights seem to be referring to ansvr 0.12 which is not the latest version. The latest version is 0.13, which you can install by following the instructions here (the second link in my prior post). Chris’s package will have 0.11 installed, but is is a good idea to get up-to-date with the latest version.


Hi Andy,

That’s where I got ansvr 0.13 originally. I still don’t understand why the command line containing “tar” did not work as per instructions from the link you gave me. I don’t remember exactly what the error message was. I am going have to re-install Cygwin again. Should I include EVERYTHING for installing Cygwin since it contains about 1GBytes? I don’t mind the extra waste since I have plenty left hard disk space so I thought installing everything would be safe and should include all necessary commands including “tar”. If I still have problems, I will document everything including taking snapshots and let you know.

Thanks for your help.



You can do a minimal initial cygwin install. Installing everything would be way overkill. Chris’s package will overlay the cygwin folder with everything necessary for plate solving.



OK. Do you remember how to select minimum install? I don’t recall this feature.

Also, maybe add a special section to SGP web site dedicated to ansvr and Astrometry.net describing how to install and setup. This way we don’t have to search for different threads of this forum.


Just accept defaults, do not add any packages.

That’s more of a question for Jared and Ken.


Ok. I think I did that and it was still a huge install. Wish me luck!!!


Andy, do you happen to know which version of Astrometry.net is in that package from Chris?

I was thinking of trying to update to the latest ver of Astrometry.net (no particular reason, just to figure out how to do it), but wasn’t sure of the best way to do that on top of an existing install.

I am now at home. I re-installed Cygwin64, then created “opt” sub-directory, installed ansvr, executed “tar” command line, updated Cygwin64 shortcut to use proper Target field, ran Cygwin64, opened SGP, checked Plate Solving Interface and finally see Astrometry.NET!!! I think it worked. The key part that was missing was the missing “opt” sub-directory and that was it!!! I thought creating “opt” sub-directory was the easiest approach so I didn’t have to install 0.11 and then upgrade to 0.13.

Thanks for all the help and possibly saving me $150 for buying Pinpoint 6.0.


I see the following statement from another thread:

Finally, restart the server if it is currently running:

go to and click "Terminate ansvr"
open your ansvr shortcut to start ansvr

Going to the link resulted “Unable to connect” and “Problem loading page” messages and I do not see “Terminate ansvr”. Has the http address been changed?


No, is a local IP address. It always points to your machine. It seems like the server might not be running. I would run ansvr with the -d option initially so you can make sure it launches and you should see it running in the terminal.

Also there is no 8 at the end of the url (although that doesn’t seem to matter):

If you use the -d option you should see this:

To stop ansvr from running you will need to use Ctrl+C (or you can terminate it from the config page)


Since you are doing a new install, the server is not running yet.

The “unable to connect” message is because the server is not running, so you can move on to the next step and start the server.


I offered to do a Teamviewer over on CN. Please send me a PM if you’re still having difficulty.

We use astrometry.net 0.38. That is the latest version that runs on cygwin – it’s the version provided by astrotortilla. Some work was done to get newer versions to run on cygwin. Apparently there has been some progress recently, but since 0.38 has been working so well for me I have had no motivation to pursue upgrading it.

So right now there is no easy way to try a newer version of astrometry.net running locally, unless you are willing to get dive in and try building the latest astrometry.net in cygwin and working with the astrometry.net developers to resolve any issues you find.


FINALLY!!! I got the following link to work:

I once again uninstalled everything and did the following:

  1. Re-install Cygwin64 using default.settings
  2. Install this *.rar from
  3. Open the *.rar with 7-zip
  4. Using 7-zip, carefully highlight all files and directories under:
    C:\Users\your username\Downloads\cygwin.rar\cygwin\cygwin\
  5. Drag the highlighted files and directories to C:\cygwin64. Over write all files already on your computer.
  6. Follow instructions from:
    Ansvr-0.13 - add JNow config option

After executing ansvr server, you should be able to connect to:

If you cannot connect, then there’s something wrong.

What a nightmare but what do you expect from free software.

My next test is to try it out under the dark sky but it’s currently cloudy. Must be a “Finally got it to working” curse.


The local server displayed a bunch of blank boxes for me to fill out. Do I need to fill them out or leave them alone?


Peter, Glad to hear you got it working.

Don’t touch anything there. The default settings should be fine.

You do not need to wait for dark skies to try it out. Open one of your subs in SGP, right-click => Plate Solve => Blind Solve will invoke the local solver (assuming you followed the directions about setting up the blind solver in SGP, the first link in my response to your original post, specifically the part about Equipment Manager.)


That worked!!!