UI hanging while disconnecting ASCOM camera

My sequence finished and the taskbar entry was still showing the moving green bar like it does when SGPro’s doing something. I disconnected the camera and focuser. When I tried to disconnect the ASCOM mount (Software Bisque) the user interface hung - I can’t move any SGP windows or click on anything. The last two entries in the log file at this point are:

  • [11/21/20 07:52:19.977][DEBUG][Main Thread][NONE] Disconnecting ASCOM Telescope: ASCOM.SoftwareBisque.Telescope
  • [11/21/20 07:52:26.845][DEBUG][Equipment Connectivity Thread][NONE] SGPro thinks the telescope is connected, but it’s not, syncing UI…

I exited The SkyX and it didn’t help (although SGP popped up a notice that “External disconnect of telescope detected”), so I tried closing SGP by right clicking on its taskbar entry and selecting Close.
SGP popped up a dialog box saying “SGPro still has gear connected. Are you sure you want to exit?”, but I couldn’t click on it or move it.

The log file now had these lines:

  • [11/21/20 08:05:14.661][DEBUG][Main Thread][NONE] Adding sequence level notification: External disconnect of telescope detected…
  • [11/21/20 08:05:14.683][DEBUG][Equipment Connectivity Thread][NONE] Sending Notification: Warning - External disconnect of telescope detected…
  • [11/21/20 08:05:15.547][DEBUG][Main Thread][NONE] Disconnecting ASCOM Telescope: ASCOM.SoftwareBisque.Telescope
  • [11/21/20 08:05:15.547][DEBUG][CP Update Thread][NONE] ASCOM Telescope: Error in GetCurrentPos : GetAndFixRaDec (ASCOM.NotConnectedException: GetAndFixRaDec
  • at ASCOM.SoftwareBisque.Telescope.CheckConnected(String message)
  • at ASCOM.SoftwareBisque.Telescope.GetAndFixRaDec()
  • at ASCOM.SoftwareBisque.Telescope.get_RightAscension())
  • at ASCOM.DriverAccess.MemberFactory.CheckDotNetExceptions(String memberName, Exception e) in C:\ASCOM Build\Export\ASCOM.DriverAccess\MemberFactory.cs:line 559
  • at ASCOM.DriverAccess.MemberFactory.GetTargetInvocationExceptionHandler(String memberName, Exception e) in C:\ASCOM Build\Export\ASCOM.DriverAccess\MemberFactory.cs:line 663
  • at ASCOM.DriverAccess.MemberFactory.CallMember(Int32 memberCode, String memberName, Type[] parameterTypes, Object[] parms) in C:\ASCOM Build\Export\ASCOM.DriverAccess\MemberFactory.cs:line 230
  • at ASCOM.DriverAccess.Telescope.get_RightAscension() in C:\ASCOM Build\Export\ASCOM.DriverAccess\Telescope.cs:line 765
  • at si.kc(Boolean A_0)

I assume the last set of log entries implies a bug in Software Bisque’s ASCOM driver, but what could have been causing the SGP user interface to hang? I had to force kill SGPro via the task manager.

I’m running SGPro 3.2.0.613 on a Windows 10 PC

I have this problem on rare occasions with my Paramount. I traced it to a coms fall-out, as another device that connected to it by ASCOM had the same issue.
When this occurs - go back into the ASCOM settings and check that some of your enabled options have not been reset. Don’t know why, but I suspect it is downstream of SGP.

Buzz,
How do I check the ASCOM settings? If it’s via SGP, I’ll need to force kill it, then get back in and check, correct?