Unable to connect to FlatMan-XL

I just got an 18" x 18" Flatman-XL. It works fine using the Optec software - can connect and change brightness. Trying to connect in SGP (versions 3 and 4) fails. SGP gets no response from the unit. The error in the log file is
Caught exception in AlnitakFlatBox:SendSerial: Timed out waiting for received data.
I can use my Flatman-L just fine (12" round unit).
I am using the cables that came with the unit, which includes a USB to 3-pin connector that connects to the converter unit.

Any ideas?

I don’t have a FlatMan panel, but built my own using an LED panel from Amazon and an Arduino Nano. However, the programming uses the protocols for the FlatMan series and when I use it with SGPro, I connect it as a FlatMan panel. I wouldn’t claim to be any kind of expert on Arduinos, but I have spent many frustrating hours trying to get them to talk to PCs over the serial connection, and this may be where your problem is. The way to check this would be to try to get into a conversation with the FlatMan panel (in these times of Covid, any conversation is welcome!) using a serial console - one of the most common ones is PuTTY. You need to know what com port your FlatMan is on and you can open up a line of communication with it using (e.g.) PuTTY (which looks like this in my case on com port 7). This will open up a terminal window into which you can type commands. For instance, if you type “>S000” (without the quote marks) followed by a return, if all is working correctly, you should get a response on the terminal of “*S15000”. The 15 in the string indicates that it is the FlatMan-XL. If you get no response, then either the serial settings are not right or there is a problem with the panel.
On the assumption it is a serial connection issue, then the first thing to be sure of is that the baud rate is 9600 with 8 data bits, 1 stop bit and no parity. Assuming that is all correct, then what I’ve found is that the Flow Control can be important and so it might be worth changing that - you can do that in PuTTY from the Serial category. Normally the control is “XON/XOFF” but other options are “RTS/CTS”, “DSR/DTR” or “none”. You could try one or all of the others to see if you can get a response.
Clicking on the links in the text should show a screen-grab image which might be helpful.
Good luck troubleshooting the problem.

Make sure that the Alnitak software is NOT running when using SGP. Both use the serial port to control the unit and only one device can use a serial port at a time.

Other than that we’d need to see a log to see if there are other events that are happening.


The Flatman software is not running. I tried connecting with PuTTY and don’t get an error message, but also don’t get a response.
I tried running Microsoft’s Process Monitor, but it doesn’t show anything related to COM ports, even when the Flatman software is running, so I have no idea what it’s doing differently than SGP and PUTTY.
Does anyone know of any software that traces traffic on COM ports? The Flatman-XL uses a USB to 3 pin cable so I don’t know of any hardware device that would work.

I did a google search and there seem to be quite a few of them around (https://www.com-port-monitoring.com/ or https://freeserialanalyzer.com/are a couple of examples) which seem to be able to log traffic on serial ports. I’ve never used one before so I can’t recommend any specific one, but I may give one a try as I have occasional hiccups when connecting my home-made panels. Good luck with it as I have to say, automating flats through SGPro does make things that bit easier.

Installing the new beta driver fixed the issue in SGP, but not in PuTTY. That’s ok since I was only trying PuTTY to help debug the SGP issue.


Eric, great to hear that. It’s really frustrating this kind of thing, but at least its sorted. Terry