Unhandled exception in SGP - 32bit FITs

When attempting to open a 32 bit .FIT image, SGP will advise you that it does not support 32bit FITs, and requires a 16bit image.

However, if one attempts to plate solve a 32bit image via the sequence’s Target Settings - Reference Data dialog, the program will crash.

Thanks. I have added protection against trying to solve 32 bit (or any other value except 16 bit unsigned) images in the target settings dialog.

1 Like

This issue is back. Identical to before. Attempting to open a 32bit FITs will give a dialog, but attempting to plate solve will crash SGP.

Win7 64bit

You will need to be more explicit in your reproduction steps… this is the message I get:

  • I click the gear icon for any target.
  • I click “Browse” under “Reference Data”
  • I select any 32 bit .FIT file
  • The RA Hint, Dec Hint, Angle and Scale do not populate.
  • I click either “Solve” or “Solve Blind”

SGP crashes. (Sorry, can’t give you a screenshot of the error message right now, have a sequence up, don’t wish to restart/reconnect everything)

File that threw the original error.

Tried 2 others at the time, same result.

Ok. I don’t think you can produce the issue with the solve button, but I was able to reproduce it with the blind solve button. BTW, the image link points to a 16-bit image. The other error has been fixed though.

Hrm…thought I got it with both. laptop’s packed for a weekend trip right now, but I’ll check tonight.

Ack, you’re right…I uploaded one of the raw frames not the stack…sorry about that.

[quote]The other error has been fixed though.

All’s well that ends well, thanks! :slight_smile: