Unsure of what went wrong?

Session ceased and Log indicates many errors?

I run SGP in a Windows 10 virtual machine on my MacBook Pro so I feel like many of the errors in the log files could be related to this and the ‘drag’ in communication between laptop and gear (I notice this with guiding in particular). I was really hoping to understand why the session stopped last night and whether the errors in the log are solvable with different settings or behaviours (other than buying a dedicated Windows running laptop!). I feel it isn’t your wonderful program but more what I’m doing with (or to) it. Any help in making sense of the log files would be great so I can better tailor the way I’m doing things :slight_smile:

Link to Logs

Useful Info

OS: Microsoft Windows 10 Home
.NET: 4.8

This looks like something we should address inside SGPro. These errors are coming from the new “Notification Center”. I suspect you see the error before others due to constrained resources in the VM, but others would see it too. Until we figure this out, I think you can prevent it by filtering out “Info” notifications using the filter on top of the notification center.

Thanks for looking at this Ken. I’ve deselected the info button in the Notification Centre and deselected all the buttons in “Notifications & Popup Filters” in Tools>Options>Sequence Options

Version contains better memory management for the notification center. This kind of stuff is notoriously hard to test so it will either be better or the same… we shall see.

1 Like

No problems tonight with the notifications disabled. One other small issue (again I’m sure it’s very much Virtual machine related) is that there is a significant wait/lag when trying to close the Autofocus routine with the given button (rather than wait for it to time out and close). The same wait/lag happens when I try to click cancel after a pause to continue the sequence. Might be random and I’m sure all my fault for trying to run this the way I am.

Not sure where that lag is coming from, but you can adjust the “delay” and set it to 0 seconds in auto focus settings.

1 Like

Will do. Same lag with end of sequence options but I’m sure it’s just my VM. There was one odd thing last night where a completed event seemed to reset after my flat event (no green bar indicating it had completed). Might be a setting I’ve missed though.

It can be hard to tell. I will look at logs if you want.