UPDATED with log: Severe PhD crash with SBIG API and current beta

I just tried my Windows 8.1 laptop with all the latest builds:

SGP 2644 beta
New TheSkyControlled Telescope Driver
PhD 2.4.1c

Windows 8.1 64 bit fully updated plus I uninstalled the older PhD/API/SGP/TheSkyControlled Telescope Driver softwares and ran a registry cleaner before installing the above new versions.

I had instant crashes of PhD trying to do any kind of exposure with PhD2, even darks (in fact, I could not get beyond guider darks).

It was fine when I connected direct to the camera selecting SBIG instead of the SGP API.

I will post this to both PhD and SGP forum because it looks to be either the API,PhD, or some combo.

Original logs are at:


FYI, I had forgotten to enable API logging but have now done so and here are the new logs, very short as it crashed when I asked PhD to take a set of darks, these also have the latest SBIG drivers so everything used is current:

New Logs

Given that I was also having crashes when trying to track (darks were fine) with the older 2.3.x and older API and older PhD (these are on my desktop), I am a bit concerned that I may have an iffy setup in terms of getting image data. That is a real puzzle since those versions worked for months with the same hardware and same connections. I will try the 2.3.x and a shorter guide time tonite (as timeouts were the problem with that).

UPDATE: Last night I ran the entire night with, PhD 2.3.1.i, and API 1.1.0. This has been my normal go to set of versions for some time. Although I have seen a few PhD crashes at times with these, overall they have been very good and last night ran all night with 3 different objects as well as a flip and darks with zero trouble. I would like to test the beta and will do so on my laptop once the API issue is fixed, my desktop production machine will have to stay 2.3 et al until 2.4 and the API are stable.

WHAT I CAN SAY FOR SURE is that the 2.4 beta crash with the API is consistent and immediate - it will basically not allow PhD to work at all with the API.

That needs to be dealt with before anyone with an SBIG self guide camera can even test the beta.

I’ll do some additional testing this evening to see if I can corner this issue.

Are you using the internal guider or the remote guide head?


“Internal Guider” on the STT-8300. In actuality that is really more like the guide head on (for example) an 11000M since although it is built into the filter wheel that is attached to the camera, it is plugged into the camera with a cable (they use an HDMI cable for that - probably because it was a readily available cable type). I have always selected “internal guider” with 2.3.X (which works fine there). That does make me wonder if selecting the remote guide head might work. I would like your thoughts on that (or from anyone who has tried this with an STT and self-guide filter wheel). I can try setting it to external guide head if you think it would help diagnosis.

This is the self guide filter wheel:

This is the camera/FW assembly (red arrow to cable):

I think this could be related. I am also getting a PHD crash. Here are the details
Windows 8 (up to date)
PHD 2.4,1c r1364
SGP 2.4.2644
Camera SBIG STT-8300M with FW8G

All logs at

Steps to reproduce

  1. Start SGP
  2. Connect camera and filter wheel
  3. Start PHD
  4. Connect SGP API

In PHD start the cycle

The crash is consistent and NOT present in 2.4.1b
Per PHD folks
"The event log indicates the fault is originating in the .NET framework, in
other words in the SGP API Guider code. I think this needs to be looked at
by the SGP API Guider developers (Main Sequence Software). Please submit
the report to MSS. "

Interesting, so maybe not the API but something in the latest beta or some combination of the two?

BTW, I just tried setting it to “External Guide Head” with the same crash.

Same here: The setting is internal guide head.

OK, now this s VERY odd. Andy sent a version of PhD that had more logging (as far as he said, nothing else changed).

It DID NOT CRASH where the other version did, taking a darks library. I will test on the sky the next time it is clear but this looks like maybe Saturday if the forecast is right.

All three logs are here:

Latest Logs

Andy and I have been in communication testing this through a lot of different scenarios. Unfortunately we’re still not 100% sure what’s causing the problem. I tested his latest development build which he hasn’t released yet and it was working (2.4.1c was failing on all 3 of my machines).

So hopefully this will work, but I would still keep a watchful eye on things since we haven’t been able to track things down.


Yes, I have noted a fair amount of message traffic on the issue. Good to see it is being looked at. I will check out the next versions when available and when my weather allows.

Take Care

There is a new version of PHD2 available, v2.4.1d, that should take care of this. SGP API Guider users should definitely upgrade to 2.4.1d if you are using v2.4.1c which seems to be the version that triggers the crash.


Thanks Andy! I will download it and give it a try, at least on the bench as my skies are not cooperating right now.