Use of as local blind solve

There are two problems here:
1 - Although I have carefully edited SGP to use ‘other’ as local, everytime I invoke it (currently testing) it ignores the setting and uploads to the net.

2 - Please note that SGP is not passing RA+dec data from loaded images to the plate solve menu so every time I use it I have to enter the same data as is already in the header.



  1. I’m assuming that you have set up ANSVR according to these directions, including setting the end point? Note that even with the local version of SGP still reports "Uploading and Solving (waiting on

The above image was opened in SGP and blind solved without any hint data be entered, just read from the image.

I’m not sure I understand what you’re saying about RA and DEC not being passed to the plate solve menu. If you are blind solving then astrometry reads the coordinates from the fits header and you don’t have to enter anything. But I have a feeling I’m not following your question correctly…

OK, thanks Joel
The message ‘uploading’ indicated to me that it was uploading - I didn’t realise that it was still analysing locally, assuming that it is doing it locally - because I now won’t know unless I disable the internet connection.

What I meant about RA+dec is that I am loading (open image) a file that includes a full fits header, but when I select plate solve it comes up blank (ie without any hints) even though the info is in the header. So I have had to repeatedly enter the RA+dec for every solve attempt. Agreed that when I use ‘blind solve’ then that is not needed.


Hi Lawrence,

If in doubt, you can look at the ansvr log while it is solving: Windows Start button > All Programs > Local Solver > Watch ansvr log.

When ansvr is solving you will see lots of gibberish scrolling by. You can close the log window at any time; it only shows the log, closing the window will not affect the solving which continues to run in the background.


That is strange. Can you provide an image that I can take a look at?
Whenever I open an image in SGP (taken with SGP), right click and plate solve, the RA and DEC is filled in. I’m suspecting that the info isn’t actually in the fits.

This happens to me too. I am using PlateSolve2, and if I solve an image from Astrobin that contains the RA and DEC, it solves it immediately. However, if I solve an image taken by SGP with a full FITS header, it goes through the whole solving process, even though the RA and DEC should be in the FITS header.


My images were not taken with SGP (so far) because I’m still migrating from Maxim; does this explain it? The fits header does contain the RA+dec though. I can’t do a local upload of a file because fits is excluded - and other formats would lose the header. If required, I can use dropbox.
FWIW, I carefully entered the ansvr end-point address but nothing has invoked it. Only when I use the web (for does the image go off and get solved. My ‘other plate solve options’ settings are identical to those shown in the help facility (using port 8080). The instruction shown does say ‘open an image’ in SGP, rather than '…taken by SGP. Is this significant? When I watch ansvr it only shows ‘listening’ but apparently never hears.

I forgot to mention: I could not find any download from SGP for Platsolve2 as such, so I don’t know whether I have not installed the correct version? I used the suppliers download site before I realised that there is apparently one via SGP. However, the settings were all done via the SGP link.

Sorry for my steep learning curve - but I am making progress.


This might explain why the RA and DEC info isn’t auto-populating, but I don’t know enough about the info in fits headers to know for sure. But regardless, the local astrometry blind solver should solve the image without that hint data (hence “blind” solve). Also, it sounds like ansvr is not working correctly if you aren’t seeing any activity in the ansvr log.

Please do post a dropbox link to one of the images you’re trying to solve. I’ll see if I can solve it on my machine.

Regarding Platesolve2, please see the following link:

You don’t need to download or install platesolve2; it is included in the SGP beta(?) install. However, you do need to download the astrometic index, APM catalog. The above thread should guide you.

I am certain that I have installed PS2 correctly but the ansvr fails every time. The log file shows that it fails in 1 sec. The setting for blind solve is correct: so I cannot see what else I could do.

PS2 itself works OK when I enter all the readings from a loaded file manually. Blind solve simply fails before being looked at.


Sorry Lawrence, I’m at the limit of my knowledge with this. Just to clarify, have you downloaded the correct astrometric indexes for your image scale? (All Programs/ Local Solver/Index Downloader). That will show you what indexes are on your computer.

Beyond that, I have no idea. Andy, Ken or Jared will have to weigh in at this point.


If your imaging PC has internet access, if you want to setup a TeamViewer session I can log on to your PC and check your ansvr setup. If you would like to pursue that, send me an email with the teamviewer connection info to


Hello Joel and Andy

I have replied privately to Andy with details. I want to thank you both for this; I feel that I have taken up too much of your time so I am going to wait until at least after my next realtime imaging session. We have several cloudy/wet nights forecast so you should get a welcome break from me :wink:

Again, thanks.


Don’t worry about it Lawrence, that’s why the forum is here, to help.

Can I seek help on a stupid mistake that I just made? I have been checking/editing entries on the equipment profile manager that hadn’t been saved. Then I decided to change the location to an easier access point (not noticing where it was located…). Of course, when I restarted SGP all the data had been lost! Can someone tell me where I can find the original file? Presumably something like /users… etc?

Thanks so much.


Open SGPro, go to the Help menu, choose Open Log Folder. Then navigate to the “Sequence Generator Pro” folder. Any file in there ending with .sgp is a profile.

Got it!! It nwas in a hidden folder - hence I didn’t find it first time.

Thanks so much! :grinning: