Using a Filter Drawer instead of a Filter Wheel

I use a filter drawer in my image train instead of a filter wheel and manually change filters as needed after a pause. In the Equipment Profile for Filters there does not seem a selection to account for this. I tried using the “Manual Filter” selection and then select the filter I’m using from the list of filters I created in the profile in the sequence but when I start the sequence I get an error that there is no Filter Wheel associated with the profile which is true. Can’t seem to resolve the issue. Anyone have any ideas?

I’m about to use a manual filter myself for the first time next week. I will try it out.

As a workaround - you could create a sequence with different events based on filter selection and put a pause inbetween the events?

Manual filter system works just fine. I selected manual filter wheel in the sequencer equipment drop down list and in the control panel, put in the filter names that I would need in “define filter list”.

In operation, SGP puts up a dialog to ask you to confirm the filter name is ok to proceed at the start and for each change.

Just a thought - just scan through all the other settings to ensure that no other parts of SGP require a filter setting (AF/Platesolving etc.)

Ok, I’ll try going through that. I’ve selected Manual Filter and created the list etc but when I start the sequence I get an error that no filter wheel is attached - which is why I thought I told the system it was manual to begin with.

Thanks for the response.

I too use a filter drawer and have set up a list of the four filters that I use in it - I’ve done it not because I change the filters during an imaging session, but to keep track of, for instance, the fact that I have used an Optolong L-eXtreme filter so that the information gets recorded in the FITS header to help with file identification and processing. Having set up a sequence with the manual filter wheel selected and connected, I find it best to set the filter through the filter wheel docking module otherwise the sequence will prompt you to do it when you start it. Other than that, it all works fine.

Have you connected the manual filter in the sequence - if you just select it but don’t connect, then I guess SGPro will throw an error.


Sorry it’s taken a while to respond. Thanks for the response - I’ve tried using the manual filter wheel selection and connecting but I still get an error when I try starting the sequence.

So what I do is as follows:

  1. Assume I’ve already set up the manual filter wheel with filters 0-NoFilter, 1-LeXtreme, 2-AstronomikUVIR, for example.
  2. Choose the manual filter wheel in the equipment set-up for the sequence.
  3. Select the filter to use for the images in the sequence - say I use LeXtreme.
  4. Connect the equipment, including the filter.
  5. Go to the Filter Module and select the LeXtreme filter from the drop-down list and set it - there will be a dialogue box opens up that will ask you to confirm you’ve manually set the LeXtreme filter.
  6. Run the sequence.

The only times I’ve ever had a problem is if I don’t select the filter through the filter module first, then I keep getting boxes thrown up asking me to change the filter.

Hope this solves the problem for you as I’ve never had issues doing it the above way.


Thanks Terry. This did solve the problem.