Using Stellarium and SG Pro

I am trying to run SG Pro on a Celetron AVX mount using Stellarium as planetarium software. I am finding that the two programs will not run at the same time. I have to use Stellarium for object acquisition then close it in order to use SGP. SGP will not run otherwise. I don’t know if this is a problem that is unique to the AVX mount?

Also, is there a planetarium software that I can leave running in the background while using SGP?

Also, is there a planetarium software that I can leave running in the background while using SGP?

Yes, e.g. Cartes du Ciel works without any problems, see en:start [Skychart]


Yes! Tried it and it works great…Thanks!!

There must be a glitch with your system somewhere. I’ve been using Stellarium with SGP for years.

what kind of mount? Gitches in computers…who ever heard of that?

1 Like

The mount doesn’t matter (I’m using AP1100). Are you using StellariumScope, or trying to control the mount in Stellarium with the built in telescope controls?

Through ASCOM both SGP and Stellarium (with StellariumScope) should be able to talk to the mount. But according to the OP when you have Stellarium running you can’t even open SGP, which doesn’t make sense at all.

It may not make sense to you but that is indeed what happened. Cartes du Ciel worked fine

Oh I believe what you said is true. What I should have said is that it’s weird that SGP and Stellarium can’t be open at the same time. Especially since myself and many others use it all the time.

I wish I could help more…

Yup, thanks man. It does not make any sense to me either. I had a friend helping me with a strong background in programming and computer systems. He just could not get it working. I wish we were able to figure out what the problem was. After a few hours we threw in the towel and went to Cartes du Ciel. It work right away…go figure. I will try to use Stellarium again on my G11 GT mount and see if it makes any difference.

I use CdC and SGP too.

The Mosaic and positioning planner in SGP doesn’t support some objects ot named stars (not that I could work out) and sometimes I want to slew to a bright star to do an initial manual focus, for which I use CdC.

Would be nice if a selection of bright, named - stars were supported in the planner?

@AJS - still not clear if you were using Stellarium Scope or trying to connect to Stellarium directly. It does not surprise me at all that you had a ‘glitchy’ experience with Stellarium. I had a similar experience with a different Celestron mount in the past. My impression at the time (rightly or wrongly) was that either Stellarium Scope was not stable or that the resource requirements for Stellarium (which can be significant) was too much for my computer at the time.

I really like Stellarium but will not try to use it for mount control. CdC is great for mount control as is Starry Night Pro (but SNP is not free).

Only (rather lame) suggestions I could make would be (a) upgrade to latest version of Stellarium (b) consider using a beefier PC.



I’ve been reading this thread and it got me wondering it there might be a misunderstanding between Stellarium and Stellarium Scope. I’ve been using Sterllarium and Stellarium Scope with my Celestron mounts and SGP for years and they play well together. I like using Stellarium because of the GUI I find it more intuitive than some of the other Planetariums I’ve tried in the past. I notice several folks mentioned Stellarium Scope but I noticed in your response there was no mentioned about Sterllium Scope so that got me wondering…

Anyway for Sterllarium to attached to the Celestron Driver so multiple connections can be made Stellarium must be connected via the Sterllarium Scope Driver. The Stellarium Scope Driver can be downlonad here:
Download StellariumScope.

Here’s a screen shot of Sterllarium Scope:

Notice the Connect box: ACOM Celestron Telescope.

It does take a little time getting Sterllarium and Stellarium Scope configured but once it is done Stellarium and SGP plays well together via the Celestron ASCOM driver.

I hope this helps,


I am using Stellarium for planetarium/target acquisition purposes not Stellarium Scope. I will give the recommended driver a try. Thanks for the help and advise.

You need to use Stellarium Scope with Stellarium, it won’t work otherwise.

1 Like

Issues like this typically happen when one application is running as
administrator and the other isn’t. Make sure everything is running at the
same level (as an aside sgp does not need to be ran as admin)


Jared Wellman
– Co-Founder and Developer