Waiting for Equipment Idle


When told to slew or center, the mount dutifully slews to the right location.

But the program freezes.

If it is just a “slew to,” it just sits there displaying “waiting for Equipment Idle.” (or words to that effect).

If it is part of a “Center” command, it slews as it should, and then just sits there.

I have waited more than five minutes (as timed on the phone timer). Still nothing. I abort the “Center” routine, and I can do no more with SGP. It is just frozen.

On Wednesday, the whole system was working fine, with all the slews, solves, imaging, shutting itself down, and all. On Thursday with no changes anywhere, it acted as described above.

I downloaded the latest release of (64 bit) SGP, and tried again. Same response. I went back to what I thought was another installation of SGP (on the same computer). It was, I believe the 32 bit version that used to work fine before moving to the 64. Still the same problem.

I several times shut the system completely down, and brought it back up. Still the same response.

I checked cables and contacts several times.

It sounds like SGP is not getting a “I have finished slewing” from the AP1200.

I changed to a different acquisition manager, and took four hours of forty some exposures with the same equipment. No disruptions…Everything worked fine.

Any ideas?

By the way-----How do I tell the 32 bit from the 64 bit SGP program?

LOGS: The link to the log files for both SGP and the AP ASCOM driver can be found here:

AP1200 Mount. Driver updated two months ago.
SX 35 camera and SX Filter wheel. Robofocus, Windows 11.

Do not know number of version, but started with an August download, and then downloaded the newest last night…no difference in operation.

I cant help with you problems but, on my Windows 10 Pro computer SGP 32bit and 64bit are installed in separate locations and the start menu folders are labeled accordingly. If I hover my mouse over a shortcut link, it displays Sequence Generator Pro 64 bit and when it is running, it displays Sequence Generator Pro 64 bit (subscription active) in the top left of the program. Finally, if you download the updates, they are labeled with the version number and (32bit) or (64bit) in the file names.

It’s not the telescope presenting itself as a problem, but rather the observatory never reports that it finished slewing.

[10/05/23 20:28:40.929][DEBUG][Telescope Thread][CE;] Telescope: Slewing to JNOW RA: 19.6994992550446 Dec: 11.0685679367994
[10/05/23 20:28:40.929][DEBUG][Telescope Thread][CE;] Telescope: Calling Observatory Slave Slew
[10/05/23 20:28:40.931][DEBUG][Telescope Thread][CE;] DestinationSideOfPier Received from telescope as pierEast
[10/05/23 20:29:01.786][DEBUG][Telescope Thread][CE;] Scope reports it is done with synchronous slew, verifying...
[10/05/23 20:29:01.866][DEBUG][Telescope Thread][CE;] Telescope: Observatory is reporting slewing

We can take a look at the trace logs for the observatory if you’d like…

Do you mean like if you have both running at the same time? Or how to tell the difference between the installs?

Thank you, Ken.

I wonder what happened from one night to the next?

I did not even expect it to be using observatory control. I always control my observatory manually. That is, I open and close the roll-off roof by pushing a separate button on the wall, not by telling the software to do it for me. Furthermore, I have often operated with the roof only partially open (3/4 open on windy nights–enough to clear the scope on southern targets).

I will have to check the setting and make sure it is proper. But, again, what happened in between Wednesday and Thursday that it would work one night and not the next?

Thank you for your sleuthing.

On the above issue, it might be nice to have a more specific error message. Instead of a generic “Waiting for Equipment to idle,” if it had said “Waiting for OBSERVATORY” to idle, I would have narrowed my troubleshooting. (I tried camera as well as mount to see what was not sending the signal. I did not think to check observatory. )

As to how to recognize whether I am using the 64 or 32 bit software, I went looking at “About” and in various other places in the program to tell me, and I found no place that mentioned whether it was the 32 or 64 bit system. I know I have loaded both into my system. But I could not tell once it was running. I see The Harvester has made some suggestions. I should pay more attention.

Thanks again, I will check it all out next time I get to the desert.


Alex, did you ever find a solution to this issue?
I see it at every solve, no OBS in profile.
Tim McCollum

I had three successful nights this last weekend. Before the session, I disconnected anything related to observatory control in the equipment profile.

And, everything worked fine. (well, the roof worked fine because I was doing it manually and SGP was not at all connected. The rest of the system did everything it was supposed to do for three straight nights. )

I just wanted to have a successful session, and did not need observatory control to do that, since I am accustomed to using the wall push-button to open and close the roof.

At any rate, it all worked for me.

I suppose next time out I should reconnect my obs controls in SGP and see if it works for me.