When I add OpenPHD as my guider imaging plans don't run - it just watches the guider all night?

So I am sure this is an operator issue.

My imaging was going fine until I decided to set up all my imaging gear instead of just my camera, mount, focuser and filter wheel. I added in I have a dome (controller POTH → Maxdome) a weather monitor TempPerHum and under Device profile I think I told it I use OpenPHD to guide - and not to bother to dither (yet).

From memory I went to Tools → Equipment Profile Manager → Auto Guide and changed Interface from No Auto Guider to PHD2 with my main PHD2 guide camera profile selected. I did not select dither options nor any In Sequence Directiions (wonder if I was meant to say restart current frame when guider distance is > X.X pixels)?

So the first night I try to run it all - with OpenPHD guiding very, very smoothly in my astrolab - typically 0.4 RMS all night and drift is sub pixel in RA and Dec per minute. Well I see it bring up a window on the far left showing all the OpenPHD behaviour and I think neat - so I press start the sequence - but nothing happens. It spends all night simply watching and reporting what OpenPHD is doing - rather than initiating an imaging run!

I ended up giving up having SGP control my camera and gear after an hour or two and disconnecting and using The SkyX to control the camera (ugh) and do my test run successfully. It was hours later I thought to change the SGP equipment profile set up to say I have no guider and try do take a whole series of dark and bias shots - and once that change was made - well everything worked well again.

So I am thinking some parameter configuration I set up caused SGP to wait for OpenPHD to do something before it would start an imaging run… Any idea what this is and how to avoid it?

Thanks all, Matthew

My gear
O/S Windows 10 Pro
Ver: SGP

You mention you changed this in the Equipment Profile Manager…did you then apply that to a sequence? Sequences won’t automatically update when you make Equipment Profile changes (this is by design). But you can go to the file menu and select the option to apply a Profile to the Sequence which will populate the values from the Profile to the Sequence.

Or you can make a new sequence from that updated profile.


HI Jason - thanks for the tip - would that be the explanation to the situation I described - telling SGP I use OpenPHD makes it appear but blocks the imaging sequence from starting?

So a small side point to note - I set this up now as Jared suggested (thank you) when I applied it it set all my fillters to this camera profile to none (as I hadn’t set up that bit of equipment in my 1600MM-c profile). So I went back and set that profile’s filter wheel and filters - then applied it to the sequence - but still the filters didn’t show - but rather helpfully a text box popped up that said go to control panels → filters and update that list too. Doing this and applin it resolved the issue of all filters dissapearing!

So a suggestion either share that in the profile manager - to also populate the filters in the control panel - or give the user the option to auto populate the control panel filters when they save the equipment profile’s filter set for that camera - it was a tad surprising / confusing when it didn’t pick up the change!

I reset the guider directory again to the correct path (it already was correct) for PHD2 / OpenPHD. On the second attempt everything just started working as expected (guider wise).

So not sure what was going on on the first attempt - it timed out waiting for a settle response from PHD2 (which normally moves my mount about 1-2 pixels a minute) - and I think I had the settle to under 2 pixels for 5 seconds (something really lose).

Now it is working fine.