Why do SGP loose camera connection?

Also, why doesnt it give some error message when failing to download image?

The scenario is this:
Intel NUC with 64bit win7
newest ASCOM and SGP
some other ASCOM stuff, ASA mount, scopeDome, lakeside focuser and SX filterwheel.I dont use guider.
The camera is atik 460ex.
I start the focus and frame loop which runs fine for a while, after some time frame and focus-image doesnt get updated but is forever showing "downloading"
Have to use process handler (correct term?) to shut down SGP.

Might be an Ascom problem for sure but shouldnt SGP at least give some error indication?
Wherever the problem might be, does anyone have some suggestion for tracking down this error?
Its a permanent setup so Cables shouldnt be the problem, if I kill SGP and restart it, it works again for a while.

I’m pretty sure this error only occurs when other stuff is connected to USB-hub, at least I never been able to reproduce it if the camera is the only thing that is connected to Ascom.
I say “pretty sure” because I never been able to reproduce it when “running dry”, daytime for example. The error only occurs when it’s very annoying.


Hi Pelle,

I have seen something similar recently with my setup. Downloading stalled out or incomplete downloads occurred about midway through a busy sequence setup.
I’m running a MS Windows Vista computer by Dell, and my gut tells me the problem may be memory related. So I’ve bumped the virtual ram up to see if this helps. Don’t know yet.
The one time this occurred, I had to do a bunch of restarts resulting from SGPro failing to proceed to the next step and aborting.
I’ll be interested in seeing if you find a solution.

Good luck.

Hi Pelle

I have too experienced this, twice in fact.

The first time the culprit was a powered usb hub which didn’t produce enough current to power a QHY5 and connect to my mount with eqmod - I replaced the powered hub: solved. The second time due to signal fading along a usb extension lead - I changed it to a repeater usb lead: solved.

I suspect your problems are not related to SGP but are usb related . . . but I may be wrong of course!

Good luck with tracking it down!


I second what Barry said. Make sure you have a good USB hub and good cables. Whenever I get a random disconnect like this the first thing I check is the USB system, and almost every time it ends up being a cable or hub issue.

Having said that, the only way to get good troubleshooting is to provide a SGP log file from when this happens.

thanks guys for the suggestoion!
I will try new USB Cables. If it is the hub that is the bromlem, then I’m screwed, the hub is the internal in ASA DDM60 Pro and I doubt that can be replaced.

I have included last piece of the atik log when this error occured
"SetPointControl, level 65, minlvl 0, maxlvl 255, setpoint -488
01:25:06.439 CoolerPower get 25,4901960784314
01:25:07.051 ImageReady false, CameraState cameraExposing
01:25:07.101 ImageReady false, CameraState cameraExposing
01:25:07.151 ImageReady false, CameraState cameraExposing
01:25:07.201 ImageReady false, CameraState cameraExposing
01:25:07.251 ImageReady false, CameraState cameraExposing
01:25:07.301 ImageReady false, CameraState cameraDownload
01:25:07.351 ImageReady false, CameraState cameraDownload
01:25:07.401 ImageReady false, CameraState cameraDownload
01:25:07.440 CanSetCCDTemperature get True
01:25:07.440 CCDTemperature get
download here keeps on forever
Note that I didnt truncate last line, nothing is written in log after “get”

Even if a bad usb Cable is the problem I’m suprised that its so hard to debug usb/Ascom problems.
There are logs of course but what I would like is an understanding of what the problem really is: congestionproblem that writers of usb drivers didnt properly handle (shouldnt that be handled automaticly by the USB stack?)
faulty FTDI driver,
users shouldnt mix com port virtualization with “straight” usb Connection like the atik460ex has on the same hub.
SGP assumes thread safe drivers,…

I see 2 roads of error seraching here
A) learn everthing about Ascom and usb programming and learn to read usb loggers
C) switch hub and see if it works
When C fails it would be nice if there was a B

any suggestion at all would be MOST welcome. Perhaps someone can recommend some good explanation from a PROGRAMMERS Point of view of how ASCOM works and how USB is supposed to be handled by the programmer.


There is another option Pelle, Work with the people who wrote the various drivers - Atik. They will be happy to work with you to resolve this.

Post your problem on the Atik forum, or contact their support. Include a FULL log, not just the bits you think are relevant. Copy this to me offline.

I wrote that driver for Atik and what’s happening is that a call to the low level driver to read the CCD temperature isn’t returning. The idea that it’s some sort of USB error could be correct. It can’t be fundamental, after all that call will have been made hundreds of times before. I’d like to find a way of detecting and recovering from this sort of low level error.

I think it’s reasonable to move this to the Atik forum as it’s their camera and drivers.


Thanks a lot Chris.
I will do what you suggested for sure. Great to hear from the writer of the driver!

Feels like fiddling around with alternatives to SGP is probably waste of time.Although it wouldnt hurt if SGP handled such errors a bit more user friendly.

What you say gives me an idea, not sure but time from start of camera to error seems like same time the set temperature is reached. I will take this to atik forum now.


I’ve been working with Atik to try to sort out what’s happening here.

There seems to be some problem that’s triggered when the temperature is read when an image download is in progress.

I’ve added more locking round the image download which should stop other commands getting in the way. I’ve also done things to improve the connection and device evaluation process. This is all in the current Atik download, available from their site.

It should help, I was using this yesterday with two Atik cameras, one guiding with PHD2 and the other collecting data and it ran with no problems. I’m connecting through a hub and an active extension.