Will not center

Everything has been working fine for some time. tonight the auto center and rotate (I do manual rotate) worked fine for a couple of attempts. I was able to get the rotate on the first try and then it started to center the target. but after the first attempt the mount would not respond to the SGPro commands. It stayed at the same RA and DEC pixel error for 8 more attempts. Then trying “Center on target” It did the same thing. It would move the mount on the first of 10 attempts “sometimes”. After many attempts, I gave up at an error of 87 pixels. PHD2 works fine. After 7 successful subs I tried “Center on target” again, but with 20 tries. It stayed at 85-84px for the 20 attempts. I gave up again and continued imaging 85px off. PHD2 worked fine. The computer is talking to the mount. The plate solve works fine.

After I flipped to the other side of the meridian I did an “auto center and rotate”. The rotate worked with two attempts, It then moved the mount once, but then it did the same as before. On the first attempt it moved to 47px error and on the next 9 tries the mount stayed at the same 47px error. I have version HELP. Any suggestions.

Just throwing out some ideas -

Have you changed any settings, even if inadvertantly/accidentally with you mouse? Eg, the synch setting or the Centering tolerance?

Do you use eqmod? If so, any chance you have loaded a pointing model from a previous session when you started eqascom?

How about your mount and cabling - anything dragging, catching? Could your mount’s backlash have deteriorated? Are your clutches tight? Any slop or flexure become apparent in your rig? Balance out?

Have you tried updating to the latest beta - any improvement?


My cge-pro does the same thing - and I have been reporting on it with logs and other tests for over a year now.

What kind of mount do you have?

There are a few different options for how the mount syncs after a plate solve - and you can try other options. But many of us see this issue where the centering doesn’t converge at all and instead gets stuck some distance away. You can look at it and see exactly what offset is needed to make it work perfectly - but the software just keeps repeating the same thing and never converges.

As long as the ‘miss’ is repeatable - it isn’t a fundamental problem with the mount that can’t be handled by the centering routine. If the misses were somewhat random that would be different - but for many of us they are repeatable almost at the pixel level.

I can only use centering when doing wide field hyperstar work - otherwise it just isn’t accurate enough. And without centering - a large fraction of sgp’s functionality is unusable - including simple multi-target sequencing. Getting coordinates from DSO-Browser? No point because it won’t end up centered. Mosaics? Nope.

But maybe one of the other sync options will work better for you.

This isn’t related to backlash or epoch or equinox - it’s the way the offset is calculated after a miss and applied to make the new target coordinates to aim for. You can look at it and ask, “Why do you keep going there? It’s obviously going to miss again. You should go a little up and to the right.” But it just keeps doing the same thing.


Thanks for the help. I have always used plate solve and it has always worked, like a hundred times in a row. Once it plate solved, it always went to the target, plus or minus 3px if that is what I wanted. Now it plate solves, but has problems centering. I have an AZEQG (AZEQ6) mount. I use StellariumScope and EQMOD at HEQ5/6.
Barry, I did make a few changes to the sync, because the night before, My friends son at 11 years old, who is interested in astronomy, wanted to see some sights in the sky. I did have a bit of sync problems and changed some of the sync settings. I never did get the sync to work the way it used to work. I think that I have the setting back the way they used to be ? If you use EQMOD, what are your “Alignment / Sync” settings. It is cloudy and I will not get a chance to use it for a day or two. I will add to this post what happens.

“any chance you have loaded a pointing model from a previous session when you started eqascom?” I have no idea what a “pointing model” is.

Eqmod’s eqascom allows a user to store synch points into a model that can build a map of pointing accuracy across the sky. The settings allow you to synch without storing the synch point, to synch and store the synch point and also to either startup with the stored synch points or to startup with an empty model.

Eqmod’s pointing model can interfere with plate solving and the iterative centering routine as the number of synch points build. It is unlikely to interfere with the accuracy of centering over a typical evening’s imaging with slewing/centering a few targets. However if the synch points are stored and then reloaded at eqmod startup, over successive evenings’ imaging, you can then get problems centering exactly as you have experienced as the internal eqmod model has sufficient number of synch points.

SGP’s manual - accessible from the Main Sequence Software Support pages, Main Sequence Software, has a section devoted to Eqmod users and getting the correct settings for flipping, side of pier and pointing models. Chris Shillito’s eqmod You Tube channel videos are very helpful too, https://www.youtube.com/user/chrisshillito. The advice and experience of many eqmod users is to not store and reload a model of synch points - SGP’s centering routine works like a charm and you will be on target in a few iterations as you have previously experienced.

In SGP I suggest you use the ‘synch’ setting in the Telescope tab.

I used to use eqmod when I had an NEQ6 and then Avalon Linear Fast Reverse. I have a different mount now and no longer use eqmod.

There are many eqmod users on the forum and I’m sure someone will chime in and help if the above doesn’t help you identify any erroneous settings in eqmod.



Thank you Barry, you where spot on. I changed the sync settings on EQMOD and my SGPro is back working like it used to. In the future I will get out my old lapy to use for viewing. Everything is again working like a charm.

Good news :grin:

Clear skies!