Windows 11 and API port blocked in normal mode

Hello Jared, Ken,

I have trouble using the API with Windows 11. If I run SGP normally (not in admin mode), then a form pops up when starting SGP, asking me if I want to run netsh.exe to activate the API port. I click yes of course. However, the port is still blocked. I cannot access the API command list at http://localhost:59590/metadata, nor can I send any API commands to SGP. From the logfile it also looks like SPG cannot open the API port.

If I run SGP as admin, these problems all go away (there is no popup form at all). I dont think this is a good solution in general, as several users have reported connection problems when some programs run in normal mode and some in admin mode.

Should I add SGP to the firewall, or netsh.exe, or both ? Or is this something that needs adressing in SGP ?

Thanks, Mikael

Link to Logs

Approx time of issue: 15:30

Useful Info

OS: Microsoft Windows 11 Famille
Ver: (32-bit)
.NET: 4.8

Here is the screen shot of the popup form;