After updating to 2.3.14. SGP wont interface with PHD2

after updating ti 2.3.14 tonight SGP is not able to start , pause or resume PHD2. I had to revert back to PHD1 and it dose not sho the graph in SGP. so is it me or is it the update. worked fine till update.

Please help us help you… have a read through this and see what other information you can provide:

lets see what I can add. was running SGP v2.3.13 with PHD2 v2.2.1 with no problem. installed the SGP update to 2.3.14 last night no other changes were made. did my normal started PHD2 connected to guider and did calibrate. then started SGP set up my sequence for m16. hit the run sequence, did the plate solve moved scope checked plate solve autofocus ran then when it went to restart PHD2 got error and ended sequence. shut all programs and tried 2 more times with the same results. then tried it with PHD1 v1.14.0 and it worked fine except that the PHD graph was not working in SGP. my log file can be found here

Robert, I have not looked at your logs and do not know if this is your problem, but you should update your PHD2 to version 2.3.0 or newer. Version 2.3.0 had some improvements making resuming the autoguider much more reliable. Earlier versions were susceptible to potential random failures when starting guiding due to timing of certain messages between SGP and PHD2.

I didn’t even realize my PHD2 was out of date. thank you for pointing that out to me. I have updated it and will post results when I get a clear night again. thank you for your time.


P.S. So far I am very happy with the demo of SGP so I will most likely be buying it when the demo is over . keep up thee great work on a greatly needed program for the armature astronomer.

thanks for the help, updated my PHD2 and it works just fine now.


However, it is true that the graph does not show with PhD1 and newest version of SGP

You need to remove the PHD2 folder from your My Documents. If SGP detects the PHD2 folder is present it will not look for logs where PHD1 would have placed them.

Also, I’m not entirely sure why anyone would want to use PHD 1 at this point. PHD2 is much more feature rich and more stable. Also I don’t believe PHD1 is currently being supported…so you’re essentially using a dead product.


Jared…I talked to many people regarding PhD1 and PhD2 guiding quality and we reached the same conclusion.
PhD2 still has some bugs that make it at random times loose the guiding star and wonder off for no reason at all without being able to correct. It happened to me 2 times in the field in a recent astroparty and I switched to PhD1 and never happened again.

If you believe you are seeing a problem with phd2, it would help the community if you post the log files. The only way for the software to improve is if the developers are aware of the issue.
The phd2 log files are in the PHD2 folder of your documents folder. There you will find Guide Logs and Debug Logs labelled by date. If you still have the files from the recent astropary I would be glad to take a look at them.

Just for balance here (and to avoid unnecessary avoidance of PHD2), I have never seen this behavior exhibited in PHD2 nor have we ever heard of this behavior (and you can trust that we are in contact with many, many people using PHD2).

@DimitrisPlatis, this is not to say you are wrong, just sharing my own experiences…

As Jared mentioned… and, like it or not, PHD1 is essentially dead. It is is everyone’s best interest to use and further the development of PHD2…

I have used PHD1 for a long time before switching to PHD2. PHD2 so far has worked flawlessly. I believe I have witnessed two or three times when a guide star would jump out of the green guide box with PHD1 and I do not think it was PHD’s fault. I believe I figured it out but I forgot what it was, it was several years ago.

I have used PHD2 with OAG and SX Lodestar (2000mm and 980mm focal length) and guide scope with SX Superstar (250mm focal length) without issues. You just have to use good PHD settings for different focal length scopes AND different pixel sizes autoguider cameras.


Dont get me wrong…I do agree that PhD2 features are amazing and I would rather prefer using PhD2 and go to sleep.
I do have the logs from the 2 nights I used it until I switched to 1. I can share though I dont remember where the exact point is where it went astray.
I have optimized the settings for my focal length and everything…so this is not an issue. I was well prepared. This has not happened many times…just 2.
I clearly remember when it happened and I think it was the Dec axis that went off. It was working fine so far…
I asked people…some of the best astrophotographers in Greece and probably the world,…and they also shared similar experiences.
I would love to have this solved…it is not a matter of discouraging people from using PhD2…but there is no point ignoring the issue. I can share the logs

These r the logsPHD2_GuideLog_2014-07-23_222018.txt (747.0 KB) PHD2_GuideLog_2014-07-23_222018.txt (747.0 KB) PHD2_GuideLog_2014-07-24_220617.txt (449.6 KB)

Hi Dimitris,

I believe you. I hope my message didn’t imply that. Like I said earlier, I did have similar experience it with PHD1.

From your logs, I see you use Lodestar and EQ-6 mount. If I remember correctly about what I experienced, it may be coming from Lodestar which has an interlace CCD. It has to do with reading odd and even lines separately from Lodestar and when the image is combined it can cause centroiding errors due to artifacts. I have read some reports that autoguiding with interlaced CCD may be problematic and people claim that they solve this issue by binning using Maxim DL. PHD does not support binning. Binning an already large pixels of Lodestar is not always a good idea.

My similar experience as yours happened maybe three times and I imaged quite a bit. Right now I am using guide scope guiding a refractor and currently use SX Superstar which has half size pixels than Lodestar so it’s not as over sampled for my 250mm guide scope. Superstar so far has been working well with PHD2. It’s not as sensitive as Lodestar but does a good job.


Thanks Dmitris. Do you happen to have the debug logs for those sessions as well?

One thing I notice is that you are not using a Dark Frame library. Without darks, there is very little protection against phd2 trying to guide on a hot pixel. In PHD2 you build a dark library by clicking Darks on the menu and selecting Dark Library. There is also an option to use a Bad-pixel map. (newer versions of phd2 display a warning if you start guiding without darks or a bad-pixel map)

I see that in some cases the star was lost when the SNR dipped below 3.0 (and star mass dropped as well.) This is almost certainly an indication of a passing cloud. This, in combination with dark frames disabled can cause the runaway guiding. So I think dark frames would have helped in that case. You do have noise reduction set to “2x2 mean” which can somewhat compensate for the missing darks. But I still think having darks would help.

There was another case in the log where the star was lost and I did not see the SNR drop first. I would like to see the debug log to get more information on that incident. You have Star mass change detection enabled, and that can cause frames to be discarded, but the debug log should tell us for sure if that was what caused it.

One more tip: if you enter your guide scope focal length in the global tab of the brain, PHD2 will be able to display guiding information in units of arc-seconds, which is much more meaningful than units of guider pixels. (Newer versions of phd2 have a wizard interface that will help setup your equipment profile, prompting you for your guide scope focal length.)

You may also want to consider increasing your max ra and dec pulse durations from 500ms. A value of 1000 or even 2000 ms should be ok. (The default value of 500 was way too conservative and was increased in later versions of phd2.) But this is not directly relevant to your lost star problem.

You can bin your Lodestar if you use the ASCOM driver to connect to it. (Though I do not necessarily recommend binning it, I get great results with my Lodestar without binning.)


1 Like

I will post the Debug logs…
Also know that I am using an OAG at 1150mm and 500ms guide duration is way too much…I rarely get more that 100ms of corrections.

1 Like

Dimitry, I found the same thing with an OAG and my lodestar. One thing to caution against is low max durations if you’re dithering. It will have a hard time re centering.

@mads0100…It was recentering within 15 secs…no problem there…thats why I put 500ms max duration

1 Like

Yea, I tried a 200ms max duration and had issues :). I set it to 600ms and it hasn’t been as big of an issue.