Alnitak Flip-Flat, SGP Integration Issue

Hello,

I am having some trouble taking automated flats with a new Alnitak Flip-Flat. Everything seems to be working correctly, but when I review my flats they often come out as darks meaning the flat panel was not illuminated.

Last night I caught the problem in the processing of happening. I completed my imaging sequence and SQP moved on to my flat sequence previously generated by the flats wizard. As I watched it run, I could see SQP claiming that the flat panel was set to the correct brightness, but the flats again were “dark”. After this sequence completed, I stopped the sequence, disconnected SQP from the Flip-Flat, and fired up the Alnitak Flip-Flat controller. I turned it on at my desired brightness and manually took an exposure with Frame and Focus (why I disconnected SGP from the Flip-Flat; it would have opened it for the test exposure). I hit my target ADU and my flat looked as I expected. I then disconnected the Alnitak controller (without turning off the flat panel), reconnected it to SGP and than re-ran the flat sequence in SQP. Everything worked as expected.

I am starting to think that SGP is adjusting the flat panel brightness per settings under filters control, but not actually turning it on. Is this possible? Is there something that I might be missing?

I’ll try to verify this with my own eyes when I move my rig back into the house.

I am running v3.1.0.479

Thanks for any suggestions.

Andrew

If you can post a log that would help figuring out what is happening:

Thank you,
Jared

Hi Jered,

Here’s a link to the log file when the failure occurred: flat light off


The flats process happens around line 15458 ~5/24/20 0:14:08

The next morning I manually intervene by turning the flat field light on with the Alnitak controller.
You can see this around 5/24/20 8:00

The primary difference I see is:
Light Status: 0
vs
Light Status: 1

Thanks for taking a look,

Andrew

I had this issue happen again last night (after a four month weather interruption). The open and close function of the flip flat works perfectly. But, when SGP runs the flats event, it fails to illuminate the flat field. Last night I happened to be up when this happened. To resolve, I paused the sequence and manually turned on the flat field with the flat box SGP widget by dragging the brightness slider. Next, I resumed the sequence and the flats were taken as expected with the predetermined duration and brightness. So it seems the only issue is that SQP fails to turn on the illumination.

I have attached my logs for this set of events.

On line 7953 you can see SGP setting up for the Flat Event. It closes the shutter, sets the filter.
Starting on line 7988 it reports:
[09/06/20 23:29:42.988][DEBUG][Sequence Thread][SQ;]Alnitak Flat Box - Updating Device Variables - Model: 99 Motor Status: 0 Light Status: 0
[09/06/20 23:29:42.988][DEBUG][Sequence Thread][SQ;] SetFlatBox: shutter move complete
[09/06/20 23:29:42.988][DEBUG][Sequence Thread][SQ;] SetFlatBox: Setting brightness 200
[09/06/20 23:29:42.988][DEBUG][Sequence Thread][SQ;] Alnitak Flat Box - Setting Brightness to 200

At this point SGP is taking flats with no illumination. I believe the issue is “Light Status: 0”.

It completes two flats before I pause the sequence at line 8134
[09/06/20 23:30:10.429][DEBUG][Main Thread][SQ;CC;] User requested sequence pause…
[09/06/20 23:30:10.429][DEBUG][Main Thread][SQ;CC;] User elected NOT to run end of sequence options!

On line 8209 you can see me messing the brightness and the shutter using the flat box widget.
On line 8572 I resume the sequence.
On line 8590, you can see the flat event has restarted:
[09/06/20 23:38:57.896][DEBUG][Sequence Thread][SQ;] ------------- Starting capture frame for event[0] -------------
[09/06/20 23:38:57.900][DEBUG][Sequence Thread][SQ;] Sending commands…
[09/06/20 23:38:57.900][DEBUG][Sequence Thread][SQ;] SetFlatBox: Frame Type is Flat
[09/06/20 23:38:57.900][DEBUG][Sequence Thread][SQ;] Alnitak Flat Box - Getting shutter status
[09/06/20 23:38:57.951][DEBUG][Sequence Thread][SQ;] Alnitak Flat Box - Updating Device Variables - Model: 99 Motor Status: 0 Light Status: 1
[09/06/20 23:38:57.951][DEBUG][Sequence Thread][SQ;] SetFlatBox: Getting filter
[09/06/20 23:38:57.951][DEBUG][Sequence Thread][SQ;] SetFlatBox: Filter 5
[09/06/20 23:38:57.951][DEBUG][Sequence Thread][SQ;] SetFlatBox: Waiting on shutter move to complete
[09/06/20 23:38:57.951][DEBUG][Sequence Thread][SQ;] Alnitak Flat Box: Is shutter complete
[09/06/20 23:38:58.002][DEBUG][Sequence Thread][SQ;] Alnitak Flat Box - Updating Device Variables - Model: 99 Motor Status: 0 Light Status: 1
[09/06/20 23:38:58.002][DEBUG][Sequence Thread][SQ;] SetFlatBox: shutter move complete
[09/06/20 23:38:58.002][DEBUG][Sequence Thread][SQ;] SetFlatBox: Setting brightness 200

This time everything works and the only difference I can see is “Motor Status: 0 Light Status: 1” - this time the light is on.

I think SGP is failing to enable the flat field light and is only adjusting the brightness or it is trying to turn on the flat field, but it is failing and SGP is not checking that Light Status variable to see whether or not it can proceed.

SGP log of flat field failure

Looking at your sequence it appears that the value for the “Flat Box Brightness” is 0.

image

While you’re overriding the exposure in your sequence, the brightness still comes from this setting and it looks like it’s 0.

You may want to use the Flats Calibration Wizard and setup the values for your camera. When you’ve done that you can also save these values directly to your Equipment Profile and you can then easily use the “Flats Wizard” to create flat events for your sequence that utilize these values with the correct exposure length as well.

Jared

Hi Jared,

Thanks for your help.

Here’s how I am setup. I have define thed flat box brightness for each filter in the control panel / profile (first screen shot). I also use the Flats Wizard to generate my flat sequence. Although I have played with the Flats Calibration Wizard I did not end up using it to define brightnesses for each filter. I do my calibration with flat-darks vs flats and bias (CMOS camera) and find I make life easier (less data) by setting up my flat parameters such that I have a single sub length for RGB flats and another for SHO flats.

But as you state, I have not defined a “No Filter” flat brightness.

So, you are saying this value is required to get the flat panel to turn on. I can certainly try setting that value and see what happens. That is something I would never have considered.

Regards,

Andrew

Only when you’re not using filters. The log that was sent didn’t seem to be using a filter for the flat so it would use the “No Filter” option.

Jared