Auto focus and recent updates


Still getting these auto focus errors and the focus positions never change from the starting point “we are lost”. My focuser is moving and all was well until the updates in the past weeks.

Link to Logs

Useful Info

OS: Microsoft Windows 10 Home
.NET: 4.8

A step size of 7 seems small and you are not really getting any variation in HFR. Because of this, SGPro is unable to determine what movement makes focus better or worse… thus the “we are lost”.

On my 70mm refractor 15 to 18 seems reliable but the initial run of the night will always fail. It throws the focus off and I have to manually focus to get it close again before it will work.
On my 10" RC a setting of 35 will work about 50% of the time, changing +or- minus by 5 and it will fail every time.
I don’t know what the step size was before this rash of updates that I never should have installed because it always worked and I never looked at it.

How do I go back to the version I had 3 months ago when I never had to think about focus on either of 2 telescopes because it always worked.

I’ve been seeing the same thing on my RC8. One day all is well the next it just would not work correctly. At first I thought it was due to the very large star in the field of view, but it seems to be like this with other targets too.
Can’t really check the last statement, because the Auto Focus Log Viewer keeps crashing.
Here’s the Logfile:!AiJtNazoGA2vgrtIxOzWo_grRWXM-g?e=aLffXw

I am not following you here. Every single AF run in that log looks good (with the lowest quality fit at 91%). What do you mean by “same thing”? Maybe that’s not the right log?

Maybe this Log will make it clearer:!AiJtNazoGA2vgrgwcyoqec16gm3oRg?e=Bhte87
Thank you


The difficulty with AF in those logs is simply lack of star data. A one second exposure is not really sufficient here. Try 7 to 10 seconds and you should be good to go.

I use 15 second exposures on my tmb130ss with Lum, and 25 with narrow band. Give the longer images a shot.

Thanks. I actually have it set to 10 Seconds, but maybe something went wrong. I’ll have to have a look at the settings again. It would of course explain the errors I’ve been seeing.Just for clarity’s sake, I did not change the duration of the exposure for AF between the two Logs posted above.


That should be fine, but the exposure length in that sequence is definitely at 1 sec so you’ll definitely want to double check. Fwiw, the AF exposure times in the sequence you provided above are 2 seconds for broadband filters and 4 seconds for narrowband. Those times are also likely not sufficient.

1 Like

Where do you see these settings? I only know about the one setting und Autofocus Settings, where I also have the Luminance filter set as the one to do autofocus with. I don’t use any other filter for focusing. I’m slightly confused. Thanks.

They are here in the filter setup window:


I never set those parameters,because I have really good parfocal Astrodon filters and I only use the Lum filter for AF. When I watch the imaging session live, I can see it changing to Lum and using 10 seconds AF. Anyway, I’ll check it all out the next time I have a clear night.

Thank you for your support and please accept my apologies for “hijacking” this stream.

Note that the area I am pointing to has nothing to do with focus adjustment or parfocal filters. If you use AF with a filterwheel, you MUST set the “AF Expose” value for every filter you intend to use for focus. There is no other area to define this parameter. For you, you only need to set the AF Expose for “L”.

Closing due to inactivity. If this is still an issue, please send the requested information and “uncheck” this thread as solved.