Auto focus issues

the attached samples from last night were taken approximately 20 minutes apart.
As you can see, focus is very good in one frame and has been hopelessly mangled in the other.
I don’t know how to eliminate focus as a reason for aborted sequences or awful subframes.
Its so random, I don’t know what setting is off.
ANY advice would be greatly appreciated

Ummm… you need to offer a bit more info.

Do you have SGP set to refocus every so many minutes? Or, every so many degrees temperature change? Or every so many frames?

Is something slipping in your image train? (That’s been the culprit for me, when I’ve had an issue like this.)

I mean no insult… but I can’t parse that sentence. What are you trying to achieve? You want SGP to abort if focus goes bad? Or, the opposite?

Hi Karl, thanks for the response.
To open, I had no idea what anyone would want for information to diagnose this. I just put my hand up and waved to see if some kind soul would wave back and try to help.
So again, thanks.
I’m running a rock solid setup remotely.
I have a TEC140 APO, with TEC Field Flattener, a Precise Parts adapter to the Feather Touch focuser.
The focuser itself is very good, a Starlight Instruments PosiDrive focuser.
The focuser itself does not slip.
All of these components are solidly connected, with good cable management.
So its reasonable to eliminate that as a likely offender.
I have SGP setup to autofocus on sequence start, on filter change, and every 75 minutes after that.
The images I posted represent the before and after auto focus images past one of those 75 minute focus runs.
When SGP fails to find focus, it keeps pushing the focuser further away hoping to find focus on a subsequent run. (smart focus?)
This continues for an hour or so until it gives up.
Sometimes when I look at the result in the morning, PHD2 is so far out of focus that it can’t guide (OAG).
And all seemingly because of an innocent command to refocus after 75 minutes.
I mean, focus wasn’t far off I’m asking SGP to tweak it mid sequence. This is pretty basic.
In terms of my statement: “I don’t know how to eliminate focus as a reason for aborted sequences or awful subframes”
The sequences are being aborted i GUESS because PHD2 can’t guide (too far out of focus) or if not aborted, maybe they should be becuase they are still out of focus just not so much that phd2 fails. In troubleshooting, focus seemed to be the main reason, so I wouldn’t discount it until I get confirmation from a second opinion that, yes, its SGP/autofocus that messing me up.
It can still be my fault! Settings probably.
But I also wondered if it was my target. Maybe SGP has trouble with globular clusters that fill the field.
I dont know.
I hope that gives you more to consider.

I’m certainly no expert in autofocus… though I do think I recall something about globular clusters being hard…

If the temperature isn’t going to change much, maybe you could ask it not to bother refocusing. But, usually, I would have expected a failed auto focus to cause the system to return to the starting point… which presumably, I mean, based on the evidence presented, was already in focus.

So, what the developers are going to want to know is what version of SGP are you using, and, if this is consistent behavior, then logs, and maybe you’ll even want to have the autofocus system do some logging. (I think that’s a thing you can ask SGP to do, but usually one doesn’t because it takes up lots of space, and isn’t usually interesting.)

So, now we wait to see if the developers will have anything to say. (They’re gonna want logs for certain, though. See: How to report issues or ask for help )

I’m envious of your set up. Wow, just wow.

Funny thing, I downloaded an SGP Logviewer, and tried to open last nights log to explore around in the logs. The LogViewer couldn’t read the focus entries. Thats telling in a way.
Thanks for that link, I’ll go explore it while we wait to see if the developers engage here… :slight_smile:


Like mentioned earlier globular clusters are hard for the autofocus routine.

Thins you can try is to turn off smart focus (it should go back to the last position instead of searching around) and increase or decrease the step size, i’d try to decrease it first.

You should try the SGP AutoFocus LogViewer (not the same as SGP Log Viewer)

This is correct :wink: we’ll need logs to see what is going on.

If you have a log for these runs and an approximate date/time when both auto focus runs happened it would be helpful.

Thank you,

thanks Jared, I appreciate the assistance.
I have a file file, I hope you can find something around 12:48am 09/02/21
Red filter image 14 has a time stamp of 12:48am and is in focus.
Red filter image 15 has a time stamp of 1:06am and is out of focus.


Hi there, I thought you were helping me, but I seem to either have lost your attention, or I’m going about it all wrong. Please advise me

On a weekend?

I took a look at your log file. I am no expert but have many years experience with SGP. I think your AF settings can be improved upon. You are binning 3x3 but your HFR is down to 1 pixel, yet you are excluding stars of 2 pixels or less. I would try 2x2 binning, if not 1x1.
Secondly - the ratio of your smallest to highest HFR is very large (over 5x), which is unecessary and actually counter productive. I would halve your stepsize.
If you look through the logs, your settings are such that there are only three stars being detected. Each time the focuser does its HFR assessment, it selects different stars randomly. If your settings are such that it does not get a suitable sample set, all bets are off.
So, in summary, I would try 1x1 binning, expose for 6 seconds and halve your stepsize.

hmm. I’m happy to wait for the SGP folks. Nothing suggested I was being impatient. In fact my humble statement that “I’m going about it all wrong” was about my approach to getting help, not my approach to focusing.
thanks for the tips.

For the most part, the forum members support each other with their insights and experience. Ken and Jared are more likely to comment if the issue appears to be unusual or a potential bug. I ran two rigs last night with an RCT and refractor with SGP on a cluster and no focussing issues. I binned 2x2, with 4 s exposures on wide and and 8 s on NB. My step size was twice the calculated critical focus zone. With 9 samples, all curves showed no dog ears and identified 50 stars or more each time.

thanks. I was not anticipating that. Especially when I got a comment from the founder :slight_smile:
Spoiled me.
In reality, I don’t fully grasp what all the settings do.
“Minimum star diameter size” for example.
The help pop - up says the following:
Adjust the value to limit the smallest star size to be considered during autofocus.
How do you know what is correct for your system?

The minimum star diameter control is designed to exclude hot pixels, which can be confused with small stars. It is set at 1x1 binning scale. I usually have good sensors with few hot pixels and set a value of 2 or 3.