Auto Guiding PHD2

PHD2 kicked on and attempted to guide but was unable to calibrate… I’m so close it hurts. If anyone can offer some advise I would very much be in your debt.

I reformatted my PC today and installed ASCOM with the associated drivers, the catalog files for planewave, SGP Pro, PHD2, EQmod, Pegasua App, PoleMaster APP, The ZWO software and Deep Sky Stacker.

I then rebuild my profile and linked SGP up with PHD2 and EQMOD. I was able to Solve and Sync for the first time! Huge success!!!

I built a sequence and was able to slew, plate solve and center. Even Bigger Success!

I need a little advice on where Im going wrong with my PHD2 setup. SGP is not mapping on the PHD2 Graph in SGP. This is another indication something is wrong and why SGP is not tracking using PHD2. I have a check mark next to ENABLE SERVER in the PHD2 settings. I built a profile in PHD2 using the wizard. I mapped the PHD2 profile in the guide tab of my SGP profile manager and control panel.
The struggle is real.


Link to Logs

Useful Info

OS: <Windows 10>
Ver: <>

You need to have the Enable Server Tick turned on.

Server is enabled, the box is ticked off as in there is a check mark next to it, it is enabled, LOL.

I have read the manual and I know that I order for SGP to control PHD2 enable server must but checked.

It was the first thing I did when I installed PHD2.

Something else I noticed while attempting to guide is that the RA DEC graph is not plotting while guiding.

Thank you for the suggestion. I welcome more if anyone has any ideas.

Thanks again!

I’m sorry if it’s too obvious but dit you enable “Display graph” in the View menu ?

Don’t be sorry, thank you for trying to help. Yes I have the “PHD2 Graph” window open and docked to my SGP Pro home page.

Just. A thought. Are you running one app as administrator?

No, I’m not should I be?

Well - once you have checked the obvious. Some apps that share an ASCOM connection do not work together if one is being run as admin but the other is not. Just something else to check off the list.

Out of interest, do you launch PHD2 from within SGP, or do it separately? The two get along just fine if you let SGP fire it up (on equipment connect or start of sequence). If you do it separately it is quite common for the two to get out of sync with each other, for instance one thinks it is not guiding and the other is guiding.

1 Like

Hey Kevin,

For what it’s worth I always fire up PHD first and connect my mount through there before bringing up SGP. Someone here years back told me to do that and it solved that problem for me.

Once I get on target and focused I go back to PHD and bring my guiding up. Once I’m satisfied with it’s guiding I go back to SGP and click on the little paper clip button in the PHD tool which will bring up a prompt from SGP acknowledging it. Just click yes and it should start working.

I’m not sure this is helpful but it is how I have been successfully doing it for 5 years.

Good luck.


If PhD2 can’t calibrate then perhaps you’ll need to solve that problem before you try to run SGP. There can be several reasons why PhD2 can’t calibrate (i.e., your polar alignment is too far off) so I suggest you post a message on the PhD2 forum. Don’t give up; you’re close.

I let SGP boot, it loads my profile and connects, but never starts tracking. It just says resuming guiding in SGP, forever.

Thanks you for the advise. I will give it a try next time I have clear sky’s. I’ll keep you posted.

I did get it to calibrate, I ended up booting PHD2 independently and let it track a star on its own for a few hours. It worked itself out.

Now I’m just having the issue where PHD2 is just don’t playing nice with SGP. Still having the communication issues.

try going into profile and click on guiding then refresh

Kevin - there is good news and bad news. The good news is that they do work together. If they didn’t the majority of SGP users would be climbing up the wall.

The bad news is that, for some reason, it does’t work for you. :frowning:

I’ll set up a dropbox and do a screen grab of all my PHD2 and guiding-related screens. Hopefully something will drop into place. Over years of using PHD2 and SGP I would firmly recommend letting SGP control PHD2. My longest running issue with SGP has been its inability to always pick up correctly when PHD2 is independently manipulated.

To the wider community - could a firewall block PHD2 server commands?

Here you go:

yes - you are manually selectively connecting things when you start a sequence, so SGP would, in this case, remain in sync. The issue that I’m referring to occurs after you connect SGP to PHD2 and then later on you turn guiding on/off within PHD2. On occasion SGP does not pick up the change in state and I have had instances where SGP times out, thinking that the guider did not resume, when it has been going all along.

The full convenience of SGP occurs when you can simply hit ‘run’ and let it get on with it. In this case SGP connects to all the devices and will power up PHD2, controlling it perfectly until is closes down at end of sequence or bad conditions stop play.

I don’t know if this suggestion has been made or not. You should first try to get each of these two software work successfully before getting them to play together. If PHD2 doesn’t calibrate (and what does that mean?) then you should work that out separately from SGP. My experience is that when calibration fails I get a message from PHD2 telling me what could have caused it to have failed.

In the end, we all want to automate the process which is why we are using SGP. However, nobody really knows why SGP fails to launch and work with PHD2 for some and it succeeds for others. The best thing is to get PHD2 running and guiding first.


Thanks, I have PHD2 Running. It was having trouble calibrating at first. It just needed time. After I launched it solo and started it tracking it worked itself out.

The issue I am having is that SGP is not resuming the sequence after plate solve. It just sits there waiting on PHD2. That being said, SGP opens PHD2 and PHD2 does everything it is supposed to do. It’s loading my profile and connecting the correct equipment, selecting a star and tracking. However, SGP is not recognizing this. In the Lower left on the status bar it says resuming guiding. Also, the auto guider graph is not plotting.


I was able to get SGP to track using PHD2 by the following:

  1. I deleting my profile in PHD2.

  2. I physically disconnected everything from my computer and closed all other programs.

  3. I then connected my Guide camera (ZWO ASI120) and my mount (EQ6-R PRO running ASCOM EQMOD).

  4. I ran the equipment wizard in PHD2 selecting the ZWO driver that was preinstalled in PHD2 NOT THE ZWO ASCOM 1 OR ZWO ASCOM 2 DRIVERS THAT I INSTALLED. If you scroll all the way down the driver list it is the very last driver listed.

  5. I created a darks library, started tracking a random star, and I then ran the guiding assistant within PHD2. After that completed I applied the recomended settings and again, began tracking a random star.

  6. With PHD2 open and guiding I physically connected my imaging train and launched SGP.

  7. I opened the SGP profile manager and selected the guiding tab, there I clicked settings. I refreshed my profile list and selected the profile I just created in PHD2.

  8. I opened the control panel in SGP and again refreshed the profile list and selected the profile I just created.

  9. on the sequence tap connected all my equipment.

  10. I clicked the link tab on the guiding graph window and watched as the graph began plotting my RA and DEC.

  11. Using the mosaic tool I started a new sequence.

This seemed to fix the problem. From time to time I had to help PHD2 pick a star to guide but for the most part it is now working as designed!