AutoFlats won't turn off my flat panel

I have a dual telescope setup on my iOptron CEM120. My Stellarvue 80 has an Alnitak Flip-Flat mounted on it. This setup works fine with AutoFlats. My second scope is an EdgeHD8 with a Spike-a flat field panel that I have mounted to my Observatory wall. I have AutoFlats setup to run before my sequence using the park position (horizontal position 2) but I have my mount always at zero position due to the cramped area in my obs.
So here is what happens when I run my sequence. The mount moves from zero position to the horizontal park position 2. The Spike-a flat field panel illuminates and the flats are captured. When flats are done, the obs opens, rotates, mount slews, guiding, plate solves, auto-focus, image capture. All as expected. But the flat panel never turns off. The work around is to slide the control in the Flat Box docking module down to zero. Does anyone know if there is a setting I missed?

It should be turned off when the sequence starts (or flats end). If I’m not able to locate a problem here, logs showing the issue would be helpful.

Maybe logs would be helpful here. Right now AF does not turn the flats panel off because SGPro should automatically do this when the camera engages in its first non-flat integration. We would need to see when that was and why it didn’t happen…

Guidance on getting logs to us:

How to Submit Logs in SGPro - Sequence Generator / SGPro Support - Main Sequence Software (

I submitted the logs. I thought it would append this thread, but I guess I created a new support thread. Sorry if I made it confusing.