Autofocus when shooting flats

I wanted to shoot some flats the other night and have to give up in frustration. SGP insisted on running Autofocus when I started the sequence. I only had Flats enabled and had not connected the focuser. Why does it insist on that? I don’t want it to change my focus when shooting Flats.

Am I missing something?

  • Lutz

SGP shouldn’t attempt to focus if it detects only calibration frames. Do you also have the options to run AF on sequence start or restart checked? I wonder if one of those is getting triggered when it shouldn’t.

Log would be helpful to also see what’s going on.


Yes, In the Control Panel I have “Use auto focus” as well as “Temperature compensate” checked. I don’t see any options related to autofocus on the sequence settings.

If you click the “Set” button by the “Use Auto Focus” there are lots of options:



However…I don’t really think anything in there will solve your problem. But I’m guessing if you disable the Auto Focus options for resume or sequence start that you might at least be able to get around the issue for the time being. I’ll have to do some additional investigation to see if that’s holding things up.

A log would be helpful to see what was triggering the auto focus.


As a basic sanity check, make sure that you have the correct entry in the “Type” (i.e. frame type) box on the Sequencer panel. I have run into grief when I forgot and left “Light” as the entry while trying to shoot dark, bias or flat frames - the sequencer then tried to do all sorts of things which were only appropriate for light frames, and if I remember correctly autofocus was one of them.

1 Like

Oh wow, did not realize the Set button brought up another dialog :-). So that one has the same ones checked as your screenshot. Will try disabling that, although it would be much better if SGP just didn’t run AT for Flats :-).
And yes, I’m sure the Type for the sequence was Flats. There were Lights in the sequence that came before the flats, but they were both completed and unchecked.
I’ll see if the logs are still on the laptop later.

Thanks. Jared! Finally putting that ASI to good use…

Yes, I agree…and I’ll double check that as well :wink: but for the time being you can either cancel the auto focus (which should continue on like normal and leave your focus position the same) or you can uncheck those options. If you’re just running the flats in a non-automated fashion then cancelling the auto focus may work.

Glad it’s seeing some love!


There was no option to cancel. It just popped up an error message saying (to the effect): “Can’t run autofocus, aborted”. I spent a long while trying to coax it to skip that step, but eventually gave up and used SharpCap.

Hm, interesting…if you can get me a log I can look. Generally mixing applications for calibration frames can be problematic. Fits can be stored in different byte or even have different number of pixels depending on what driver was used. They can also be scaled differently as a different gain and offset could also be used.


1 Like

Actually I like SGP moving the focuser per filter per offset defined in the filter dialogue. This way, I get better results with my flats especially when the filters are not parfocal. However, autofocusing is another issue and I have never seen this. Must be one of the settings…