Cannot access Target Settings in sequencer


After clicking the gear icon beside the target, the following sequence error notification appears:

Screenshot 2023-05-29 125240

What can I do?

Link to Logs

Useful Info

OS: <Window 11>
Ver: <>

Very odd. We’ll need to take a look at the sequence you are using. The sequence is embedded in the logs most of the time.

  • Open up SGPro, open the sequence
  • then send us the logs

Further guidance here:

How to Submit Logs in SGPro - Sequence Generator / SGPro Support - Main Sequence Software (

Based on the text in your screenshot my guess is that the error is related to something in Windows’ language / region settings that we did not account for…

You are totally right, Ken!

The error was definitely related to the Windows language / region settings. I changed them form “Belgium” to “Germany” and no more Error notifications were displayed in SGPro.

I switched my PC to Windows 11 two days ago and overlooked this setting. Thank you very much for the quick response and the correct hint.

Best regards from Germany


Sure, BUT SGPro should be functional in any region. Belgium was the “problem” region? I will try to recreate here.

I don’t think that the region “Belgium” is a problem. There was a problem in my Windows configuration:
The region was set to “Germany” and the regional format was set to “German (Belgium)”.
After correcting the regional format to “German (Germany)”, the problem was solved.

I think it has something to do with the time and / or date format, which is probably different in Germany and Belgium.

I am experiencing the exact same problem, but cannot get if fixed by changing the region/ language settings…is there already an official solution by the Sgpro staff?

Kind regards,


We do not have any additional information regarding this issue, only what is posted here. Can you provide additional details?

I kept playing with the language and region settings and was ultimately able to fix the problem!
You indeed have to set language and region to the same region.
I had region Belgium and keyboard France in order to have the right keyboard layout. With this combination the error occurred.
I changed the region to France, while keeping the keyboard set to France and suddenly everything worked again.
So the originally posted solution is correct! I just didn’t follow it properly…
Very strange error to occur :man_shrugging:

Oh, OK, thanks. This will be helpful in reproducing the issue. So far, we have not been able to do so.

The strange part is that on my Primalucelab Eagle 4pro ( windows 10 enterprise ) , I had this error, but on my other Primalucelab Eagle 5 XTM ( Windows 11 enterprise ) the different region / Language does not give problem. Both have the latest version of SGPro ( )

Maybe this will help…

Thanks for the very very quick replies on my questions :slight_smile: