Creating A New Target (Creating events...)

I attempted to add another target while acquiring images (maybe I shouldn’t?). A message “Creating Events…” appeared in the target window and never went away. Hovering over the target indicated the appropriate data was there but the new target was never acquired. The first target was successfully completed. Restarting SGP the following morning showed the new target and events were there. The log is at:

No, that’s fine to do. Unfortunately, this is a known issue that, so far, I have not been successful in hunting down. That said, while I have personally never been able to recreate the issue, I have taken a best guess at it in last night’s release.

Small changes and additional logging to track a rare issue where the Loading Target indicators do not hide when target load is complete.

I am always looking for ways to recreate the issue. If you find that you’ve got a way that always (or mostly always) results in this behavior, I’d love to know. Unfortunately, I suspect that if you tried again, there would be no issues (I suspect it’s timing related).

In any case, as a temporary workaround, if this happens, you can try to click anywhere on the “loading screen” and then use the Escape key to dismiss it.

Thanks, Ken. Wow, what a quick response!


You just happened to make a report when I was going through. Rest assured I don’t sit and wait at the keyboard for SGPro to break :wink:

I can’t remember the details but have had problems doing the same. Adding a new target while one is near the end.

The same problem happens to me as well. Go to Framing and Mosaic Wizard, I pull up my target from cache because I have little internet in the dome. Select my target and append to the sequence. I now have “target” and my image target in the sequence window. I then uncheck the “target” and high light my image target and start the sequence as normal. If I then go to Framing wizard again and find another image target and again append to the sequence the new image target shows up in the sequence window along with the “target”, and the running image target. I do this sometimes to be able to pull up the planning tools to see when the image target might be high enough to try. So far all is well…until you hover the mouse over the the last image target you just pulled up…the new parameter window opens up and from then on the the new target in the left side of the sequence only says loading target. You can’t delete it or get rid of it. Also a large banner that says loading target comes across the main screen. you can hit Esc but it keeps coming back at frequent but random times. If you pause the sequence you can then delete the last image target and get back to normal. If you load another target from cache again and again hover the mouse on the target the problem starts all over again. It does this every time.


Thanks for the report. We have added a lot of logging information to help track this issue. Are you able to submit the logs showing the behavior you describe?

Or… if you are not able to locate them, please let us know what version you were using. The last release contained some changes in this area.

This issue is pretty difficult to track so please forgive the detail here. This is my step-by-step interpretation of your description above. I’m hoping I have misinterpreted because I have tried these steps many times and have been unable to reproduce any kind of issue.


  • Open sequence with existing target (TargetA)
  • Open MFW, make a target (a single one?), append to sequence
  • When MFW closes, the new target is in the Target List of the Sequencer Window (called TargetX)
  • Uncheck TargetX
  • Select TargetA (maybe? not clear what and high light my image target and start the sequence as normal means)
  • Start the sequence
  • Open MFW again, make another new target, append it to the sequence
  • When MFW closes, the new target is in the Target List of the Sequencer Window (called TargetY)
  • Three targets in the list, TargetA, TargetX, TargetY
  • Hover the mouse over TargetY
  • Target Tooltip pops up
  • The target item that used to say TargetY now reads Creating events... (question: did you click anything or merely just hover the mouse pointer? To the best of my knowledge a tooltip cannot cause a target to load, but who know…)
  • A similar loading message also appears over the Target event area (question: do you know which target’s events were visible? Was it still TargetA?)

Yes, that is pretty much it. Open a new sequence and targetA is there. go to MFW get new targetX and append to sequence Uncheck targetA (I just use it for running Auto Rate Calibration for starlock on Meade LX600 and doing solve and sync to update align, and run auto focus routine, then I click on targetX to high light it…it has check mark and it turns blue when chosen as the target I want to run. Set up the event parameters…exposure, binning ect. Start the sequence running…does platesolve, and starts imaging. Go to MFW chose targetY and append to sequence. TargetY shows up as third target in list on the sequence. Nothing happens until I mouse over the targetY box…the tooltip window opens and then the fun starts. I don’t remember clicking on anything, but I could have. My wife is a programmer as well, and she always complains the client never gets the symptoms right…sorry.

Anyway this could all be a moot point. After I posted on the forum I saw you had released a new version that may have addressed this, and have already installed it out in the dome computer. We are still in the tail end of the monsoon season here in the White Mountains (5 hours North of Phoenix) but if I can see any stars through the cloud patches I will give it a go tonight and will turn on logging. Now that I know pausing the sequence will allow me to delete the targetY it isn’t such a worry anymore. The only reason I was looking at another target while the sequence was running was just to be able to pull up the planning tool to look at the target rise/set time. I hope this week to be able to squirt some internet band width to the dome from the house with a separate WIFI antenna so I can access other programs to see what might be available for the night.

I am happy to be a test monkey if you want to try things! I’m retired with a lot of spare time, and I’m comfortable knowing what to expect with SGP when something changes. I’ve looked at other programs…none of them seem to click like SGP! I mentor about 12 folks with LX600 scopes. It’s not a scope for beginners, but amazing once dialed in. Most started using APT or NINA or whatever…and had a mixed bag of repeatable results. All are now running SGP and I have been able to fine tune their processes and the images are starting to be better than mine.

If you wish, feel free to call…I don’t mind if you want to try something at night in the dome!

John Rathbun

Hi Ken,
I just went to the dome and created a dummy sequence. I still has the same bug. I will try tonight to run a real sequence without all the platesolving and can’t center errors so the log will be clean. To further fine tune the symptoms…sequence had targetA(default) used MFW to get targetX into sequence. Unchecked targetA, clicked on targetX and made dummy event and started running sequence. Went to MFW, got targetY, appended to sequence…now sequence shows all three targets. I didn’t do anything for several minutes to see if it happened on it’s own…nothing. Next moved the mouse to the right of the targetY window where the setting gear wheel is and the window opened that has the event planning…could see rise/set times ok. Next hovered mouse over the targetY without clicking…tip window opened ok, still working. Next clicked on the targetYbox ( not sure if it matters where in the box I clicked), but right away the targetY box in the sequence window changed to loading target, and the big banner across the screen also appeared. Could not delete or do anything with the targetY box at all, could hit ESC to kill the big banner, but would come right back after a few seconds.Waited about 5 minutes to see if anything cleared on it’s own, but it kept acting the same. Paused sequence, then was able to delete targetY from sequnce window.

Running SGP ver
Windows 10 pro ver 1803
computer Minix Z83-4 Pro
intel x5-Z8350 cpu @1.44 GHz
4 GB Ram


Ok, thanks for the report. Logs showing that would be great (even if you can’t get them “clean”). Appreciate it!

Hi Ken,
Here are the logs from last night.
First attempt I brought M33 in from MFW. I hovered mouse to the right to get the setting gear wheel so I could look at planning tools to see if it was high enough. As soon as I exited that window M33 window in the sequence changed to loading events and wouldn’t do anything further. Also the events window in the bottom portion of the sequence window was black and wouldn’t allow me to fill in exposure, binning ect. Killed SGP and restarted. Second time I unchecked target, clicked on M33 window and everything acted normal. I filled in the events parameters and started the sequence. I was trying many different exposures and filters…found one I liked at let it image a while. At 9:15 I went to MFW in pulled down Helix Nebula and appended it to the running sequence. Now there was target, M33, and Helix on the left side of the sequence. Left everything alone for several minutes, and all was normal. Moused to the right of Helix to get the setting gear wheel, opened up planning tools.As soon as I closed that Helix changed to loading events and the big banner started appearing a short time later. Kept hitting ECS for about 15 minutes to clear it, and the Helix window never let me delete, or do anything with it. At 9:20 I paused sequence, and was then able to delete the Helix. Sequence was totally normal after that. Hope these help. Let me know if you need more!

Thanks for the logs, that’s perfect. I think that there are multiple issues we are looking at.

  • Issue 1: a target load occurs normally, but the loading indicator does not hide as expected.
  • Issue 2: Extremely slow target load. I am quite confused by this one and I think it is the reason you experience this issue so readily while others only experience it intermittently. The target loaded at 21:20 (helix) literally takes almost 4 minutes to load into the UI. Are you using an old computer maybe? Limited RAM or hard disk space possibly? Maybe the new target has a lot of events in it? I have never seen anything even close to this. Prior to now, I haven’t seen anything take more than 7 seconds to load. Something seems odd here… This is, of course, why the loading indicator keeps coming back (the target is actually still loading…). There is a chance that the changes in 892 might resolve this issue also, but there was no specific attempt at addressing it

The build below only attempts to address Issue 1. Not sure about the other at the moment.

If you (or anyone on this thread that has this issue) would like to try a test build that attempts to address this issue through several different changes, you can get the 64-bit test build here:

Please note that I am still unable to reproduce the issue in any way so I can’t be certain if 892 actually contains fixes.

Hi Ken,
I was running version 3 with a ZWO ASI1600 MC-pro, and had no issues at all. I upgraded to a ZWO ASI2600 MC-pro, the image file size is way bigger and started noticing the images took much longer to download. It went from 5 or 6 seconds with the 1600 to 15 to 20 seconds with the 2600. I upgraded to the 64 bit version of SGP hoping that might speed the images along, but that didn’t seem to make a difference. With version 4, I have also noticed more lag in response time for hitting other buttons…changing stretch in view options for example. I was starting to wonder about CPU and memory resources hitting limits.
Would stepping down to the 32 bit version of SGP gain me anything? If not can you recommend any of the similar sized fan less computers that would be better suited for keeping up?
I will try the build tonight…thanks!

computer Minix Z83-4 Pro
intel x5-Z8350 cpu @1.44 GHz
Running Windows 10 Pro VER1803 ( need Pro for remote desktop back to the Radio Shack)
4 GB Ram, 8GB SSD drive., images are loaded directly to fast USB drive over USB3.0 so C: doesn’t fill up.

Hello again,
I just loaded the build you sent, did everything as before that caused issues, but this time it had no problems. I connect all my devices, and cooled the camera . Then loaded three different targets, and opened the planning tools window once for each. The big banner popped up for about 1 second, but went right away, not sure if it said loading event or loading target…it went away that quick. At no time did I lose the ability to select, or delete any of the targets. Good Job! I’ll run a full sequence tonight and let you know how it turns out.

Excellent… thanks for the update.

Hi Ken,
Ran a successful 3.5 hour sequence on IC5146 last night. Everything worked as it should…no Gemlins at all. I loaded a couple other targets during the run, and they all behaved without locking up, and all allowed themselves to be deleted at will. Fixing a problem you couldn’t duplicate is impressive! Thanks!


1 Like